Opened 12 years ago

Closed 12 years ago

#1463 closed Bug (fixed)

HTTPS tracker doesn't work in 1.40

Reported by: schamane Owned by: charles
Priority: High Milestone: None Set
Component: libtransmission Version: 1.40
Severity: Major Keywords:
Cc:

Description (last modified by charles)

After update to 1.40 transmission doesn't get any announce from HTTPS tracker anymore. I get "Error: Tracker request failed. Got HTTPS Status Code: 0 (No Response)"

I tried to apply tracker.patch from #1447. Now i dont get any error messages, but transmission doesn't get any peers anyway. And status is still "No Response".

Tryed to copy tracker URL and used it with curl directly in console, and i get response.

Change History (3)

comment:1 Changed 12 years ago by charles

  • Description modified (diff)
  • Milestone changed from 1.41 to None Set
  • Summary changed from HTTPS tracker doenst work anymore to HTTPS tracker doesn't work in 1.40

When you set a milestone you're essentially giving the Transmission team orders on what to work on, and on what timeline they need to do it. Don't do that unless you're going to cut us paychecks. ;)

Now, about the https issue: this was also reported in this forum thread and I'd be happy to look into the matter. However, it's working for me every time I test it. I need more information before I can get any further with this ticket.

Options:

(1) Send me a .torrent file of yours that doesn't work. Don't attach it here in trac; send it to me privately to charles@….

(2) From a terminal, set your environment variable TR_CURL_VERBOSE to 1 and then start Transmission in that terminal. libcurl will dump its debugging messages to the console, and you could mail the that output.

comment:2 Changed 12 years ago by schamane

Ops, sorry for milestone :)

Looks like i found a bug after reading forum you've linked. Just recompilation of libcurl with gnutls support makes a wonder.

USE="ssl gnutls" emerge -a1v curl transmission

Only "ssl" flag isn't enought. Its reproducible. Please close ticket.

comment:3 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.