Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1485 closed Bug (invalid)

transmission-daemon connection refused

Reported by: sala Owned by: charles
Priority: Lowest Milestone: None Set
Component: Daemon Version: 1.10
Severity: Minor Keywords:
Cc:

Description

With revisions 5500 and upwards I get "Connection refused" error while trying to connect to the socket. I have tested 1.10, 1.11, 1.20, 1.21, 1.22 and the problem is same. Last revision which was working for me was 5499. So I did just undo changes which was committed with revision 5500 and my problems was gone. http://trac.transmissionbt.com/changeset?old_path=trunk&old=5499&new_path=trunk&new=5500

However I did run into some binary linking problems, but this was easily fixed with -lintl parameter.

As OS I do run Gentoo on DSM-G600 nas.

<source> Portage 2.1.4.4 (uclibc/ppc/2.4, gcc-4.1.1, uclibc-0.9.28-r1, 2.4.21-pre4 ppc) ================================================================= System uname: 2.4.21-pre4 ppc 82xx Timestamp of tree: Tue, 27 May 2008 01:45:01 +0000 app-shells/bash: 3.2_p17-r1 dev-lang/python: 2.4.3-r4 dev-python/pycrypto: 2.0.1-r6 sys-apps/baselayout: 1.12.9-r2 sys-apps/sandbox: 1.2.18.1-r2 sys-devel/autoconf: 2.61-r1 sys-devel/automake: 1.6.3, 1.9.6-r2, 1.10 sys-devel/binutils: 2.17 sys-devel/gcc-config: 1.3.13-r4 sys-devel/libtool: 1.5.22 virtual/os-headers: 2.4.26-r1 ACCEPT_KEYWORDS="ppc" CBUILD="powerpc-gentoo-linux-uclibc" CFLAGS="-Os -pipe" CHOST="powerpc-gentoo-linux-uclibc" CONFIG_PROTECT="/etc" CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo" CXXFLAGS="-Os -pipe" DISTDIR="/usr/portage/distfiles" FEATURES="autoconfig buildpkg distlocks metadata-transfer nodoc noinfo noman sandbox sfperms strict unmerge-orphans userfetch" GENTOO_MIRRORS="http://ftp.linux.ee/pub/gentoo/distfiles ftp://ftp.linux.ee/pub/gentoo/distfiles" LDFLAGS="-Wl,-z,relro" PKGDIR="/usr/portage/packages" PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage" PORTDIR_OVERLAY="/usr/local/portage" SYNC="rsync://rsync1.ee.gentoo.org/gentoo-portage" USE="ppc" ELIBC="uclibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="dummy fbdev v4l" Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS </source>

Change History (4)

comment:1 Changed 12 years ago by livings124

Have you tried in 1.40 (the only supported version)?

comment:2 Changed 12 years ago by sala

Yes I have, but I haven't tried to fix this yet. 1.40 just doesn't do anything (doesn't open any listening ports and doesn't die using SIGTERM). Symptoms are pretty much same with older versions. I'll report back if undoing rev 5500 changes will make any difference.

comment:3 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

sala, thank you for opening this ticket as I requested. I wish I'd read your post a little more closely, since there are not going to be any more releases of the 1.22 branch.

comment:4 Changed 12 years ago by charles

Note: See TracTickets for help on using tickets.