Opened 10 years ago

Last modified 4 years ago

#1494 new Enhancement

Web Interface should support max speed per torrent

Reported by: duncanbeevers Owned by: kjg
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.40
Severity: Normal Keywords: patch-needed feature-disparity
Cc: andreas@…, pmugglerm@…

Description (last modified by jordan)

Web interface should allow user to specify maximum speeds per torrent, as well as whether those limits are active.

Attachments (1)

seed_ratio.patch (4.8 KB) - added by imissmyjuno 6 years ago.
#1494 patch

Download all attachments as: .zip

Change History (19)

comment:1 Changed 9 years ago by simonbcn

+1

comment:2 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

As far as I can tell, this is a duplicate of #2157. If not a duplicate, they overlap enough to not require both tickets.

comment:3 Changed 9 years ago by medicineuk

  • Resolution duplicate deleted
  • Status changed from closed to reopened

The two tickets seem different one asking for per torrent control and the other asking for globe "turtle mode"

comment:4 Changed 9 years ago by kjg

  • Owner changed from Gimp to kjg
  • Status changed from reopened to new

comment:5 Changed 9 years ago by Trantor

+1
I think more details per torrent (like connected peers/seeds) should be fine too. Maybe something like GTK ans QT ui.

comment:6 Changed 8 years ago by kjg

  • Keywords patch-needed added

comment:7 Changed 8 years ago by bed

+1

specifically, exposing the "Stay within the global bandwidth limits" checkbox would be awesome. This lets me configure the turtle mode, but if something needs to DL now, I can override the turtle for just one torrent.

comment:8 Changed 8 years ago by charles

  • Keywords feature-disparity added

comment:9 Changed 8 years ago by andreas

+1

comment:10 Changed 8 years ago by andreas

  • Cc andreas@… added

comment:11 in reply to: ↑ description Changed 7 years ago by NeutrinoPower

+1

comment:12 Changed 7 years ago by jordan

  • Description modified (diff)
  • Summary changed from Web Interface should support max/min speed per torrent to Web Interface should support max speed per torrent

comment:13 Changed 7 years ago by jordan

(Edit: removed the "specify minimum speeds" clause of this request.)

comment:14 Changed 6 years ago by livings124

#5045 requests this and other per-torrent options.

Changed 6 years ago by imissmyjuno

#1494 patch

comment:15 Changed 6 years ago by imissmyjuno

Ok, I've submitted a go at a patch. I'm new to the transmission-web codebase, and tried to follow the MVC structure and other conventions. Do let me know if you'd like things refactored a bit.

Here's what it looks like: http://i.imgur.com/b9PI5.png

I thought the Info pane makes the most sense for the input box, but perhaps down the line there'll be a pane just for various settings one can override on a per-torrent basis.

comment:16 Changed 6 years ago by imissmyjuno

actually, #5045 mentioned per-torrent ratio an was closed as a duplicate of this ticket. Shall I leave this be then?

comment:17 Changed 6 years ago by imissmyjuno

Apologies. i seem to have confused my browser tabs and commented on the wrong ticket. My bad!

comment:18 Changed 4 years ago by paulomuggler

  • Cc pmugglerm@… added

I was trying to apply this patch just now, as per-torrent ratio and bandwidth limiting is a feature that is really missed on a 24/7 P2P box. No luck though, the web/inspector.js file seems to have changed too much. Did this patch ever make it upstream?

cheers

Note: See TracTickets for help on using tickets.