Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1498 closed Bug (worksforme)

web daemon returns gibberish

Reported by: duncanbeevers Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.40
Severity: Major Keywords:
Cc:

Description

Using both 1.34 and 1.40 r7134 enabling, then visiting the web interface results in a gibberish download. No HTTP headers are present in the HTTP response. Saved response with .gzip extension and attempted to extract to see if entire HTTP response was gzipped, but could not extract.

Full response is attached, if anyone cares to analyze.

Attachments (1)

bad-webui-response (475 bytes) - added by duncanbeevers 12 years ago.
HTTP response from hitting 127.0.0.1:9091

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by duncanbeevers

HTTP response from hitting 127.0.0.1:9091

comment:1 Changed 12 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles
  • Summary changed from Mac client web daemon returns gibberish to web daemon returns gibberish

comment:2 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this. To test this, I opened Transmission svn trunk's gtk client, went to Edit>Preferences>Web, toggled "Enable web interface" on, then clicked the "Open" button. Firefox 3.0.2 popped up and loaded <http://localhost:9091/transmission/web/> which correctly showed the Web UI.

Please reopen this ticket with more information on how to reproduce this bug.

comment:3 Changed 12 years ago by duncanbeevers

The issue occurred using the web-interface to the Mac client. I've had no issues visiting the web-interface to the transmission-daemon running on my NAS.

comment:4 Changed 12 years ago by duncanbeevers

Issue did not occur with r7161

Note: See TracTickets for help on using tickets.