Opened 12 years ago

Closed 12 years ago

#1499 closed Bug (invalid)

Transmission constantly forgets download path if on external drive

Reported by: hakanw Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.40
Severity: Normal Keywords:
Cc:

Description

Steps to reproduce:

  1. Click a torrent link on the web,
  2. Transmission opens and asks where to download, select somewhere on an external drive. In my case it's in a folder called "Downloads" on an external drive.
  3. Click another torrent

Result:

Transmission always suggests ~/Downloads, even though my last folder was /Volumes/ExternalFoobar/Downloads?!

Does this have to do with the folder being named "Downloads" or just that Transmission forgets?

Change History (3)

comment:1 Changed 12 years ago by hakanw

Looking at the code, it turns out it always suggests the folder where the .torrent file has been downloaded. See http://trac.transmissionbt.com/browser/trunk/macosx/AddWindowController.m#L58

I would suggest that it uses as the default the last chosen folder (maybe only remember in the current running session), as people probably tend to download to the same place.

comment:2 Changed 12 years ago by Dakoman

under preferences -> transfers you can set the default download location to a specific folder or let it use the same folder the torrent is in

comment:3 Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Dakoman's explanation nails it. It uses the setting in preferences, not the last location. This is the intended behavior.

Note: See TracTickets for help on using tickets.