Opened 12 years ago

Closed 11 years ago

#1512 closed Bug (worksforme)

unicode characters aren't recognized

Reported by: livings124 Owned by: charles
Priority: High Milestone: None Set
Component: libtransmission Version: 1.40
Severity: Critical Keywords: patch-needed
Cc:

Description

http://forum.transmissionbt.com/viewtopic.php?f=2&t=6502

Multiple users have reported having problems with torrents containing unicode characters.

Change History (8)

comment:1 Changed 12 years ago by charles

livings124: please provide links to the other user reports too.

comment:2 Changed 12 years ago by livings124

You have the link I posted above plus http://forum.transmissionbt.com/viewtopic.php?f=4&t=6480

comment:3 Changed 12 years ago by charles

I don't even have torrents to test this with, and I'm probably not the most qualified to do this. IMO what needs to happen with this ticket is that someone actually experiencing the error needs to try out a handful of nightly builds from the past few months and narrow down when this bug crept into Transmission.

comment:5 Changed 12 years ago by charles

  • Keywords patch-needed added

comment:6 Changed 12 years ago by charles

#1572 has been marked as a duplicate of this ticket.

comment:7 Changed 12 years ago by charles

  • Summary changed from not recognizing unicode characters to unicode characters aren't recognized

comment:8 Changed 11 years ago by tiennou

  • Resolution set to worksforme
  • Status changed from new to closed

I'm currently downloading a torrent folder whose name begins with "玫瑰情人" and with a file whose name contains "玫瑰宣传". I'm able to "Verify local data" without it disappearing, and closing/reopening T correctly registers data. The torrents shows fine in the Web Interface. Something tells me this issue is no more.

Note: See TracTickets for help on using tickets.