Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1535 closed Enhancement (duplicate)

Transmission should have an on/off option for "system tray" icon

Reported by: hezy Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.34
Severity: Normal Keywords:
Cc:

Description

Currently, whenever Transmission is running, the Transmission icon is presented in the notification area (so called "system tray"). I find it redundant, since the same icon is already present in my task list (see attached screenshot). Admittedly, many people like to use the notification area as an appendix to the task list, but others (like me) prefer to use it for... notifications.

Transmission should have an option similar to the one in many programs, e.g. Pidgin. In the "Preferences" window, add a tab "Interface" with "Show system icon" that has the options "Always", "On notifications", and "Never". the second option is for notifications like "Download complete" etc.

I'm using Transmission 1.34 in Debian, but I guess this is relevant for all versions of Transmission.

Attachments (1)

TrayIcon.jpg (108.6 KB) - added by hezy 12 years ago.
Transmission's tray icon is redundant

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by hezy

Transmission's tray icon is redundant

comment:1 Changed 12 years ago by hezy

  • Type changed from Bug to Enhancement

comment:2 follow-up: Changed 12 years ago by charles

  • Keywords tray notification removed
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 1.34+ to 1.34

The on/off switch is in Preferences > Desktop in 1.40.

In 1.34, it's in the `view' menu.

This is a duplicate of ticket #943

comment:3 in reply to: ↑ 2 Changed 12 years ago by hezy

Replying to charles:

The on/off switch is in Preferences > Desktop in 1.40.

In 1.34, it's in the `view' menu.

This is a duplicate of ticket #943

Thanks for the rapid replay. I guess I missed #943 when I looked for tickets with the word tray.

Note: See TracTickets for help on using tickets.