Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1545 closed Bug (fixed)

1.41b1: speed temporarily jumps to 2x the upload limit

Reported by: charles Owned by: charles
Priority: Normal Milestone:
Component: libtransmission Version: 1.41
Severity: Normal Keywords:
Cc:

Description (last modified by charles)

reported here:

With a 55 KB/s limit, r7173 will mostly stay at 55 KB/s, but will often jump to exactly 110 KB/s or 0 KB/s for a second or so.

and confirmed by Stern:

As I mentioned in another thread, the 2*limit jumps appeared already in r7173. Still happens in r7214.

and by Debu:

By the way, I didn't think of it at the time, but it seems that the "instantaneous jump" I mentioned is *usually* 2x the upload bandwidth cap (69KBs x 2 = 138KBs). Could it be just a calculation mishap?

Change History (7)

comment:1 Changed 12 years ago by charles

  • Description modified (diff)
  • Status changed from new to assigned

comment:2 Changed 12 years ago by charles

possible fix: r7222

comment:3 Changed 12 years ago by charles

merlyn3d reports success.

Weaselboy isn't so sure.

comment:4 Changed 12 years ago by Robby

As stated on the forums in this post the problem was still in r7226. Haven't tried a newer build since.

comment:5 Changed 12 years ago by charles

comment:6 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fix committed to 1.4x branch in r7328

comment:7 Changed 12 years ago by charles

#1576 is a related bug

Note: See TracTickets for help on using tickets.