Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1551 closed Bug (invalid)

Setting per-torrent speed limit breaks global speed limit

Reported by: KyleK Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.40
Severity: Normal Keywords:
Cc:

Description

I noticed this with transmission-daemon, trunk svn 7213.

If I set a upload speed limit for a specific torrent, any torrents added later on don't respect the global speed limit.

Obvserved: Set global upload limit to 50kB/s. Added 1 torrent. Changed upload limit of torrent to 15kB/s. The torrent now uploads at a maximum speed of 15kB/s.

Added another torrent. The new torrent now uploads with about 130kB/sec. (My lines limit is at ~150kB/s)

Expected: The first torrent continues to upload with 15kB/s. The second torrent uploads at max. 35kB/s.

The global limit should be the absolute maximum of any incoming/outgoing traffic, regardless of any existing per-torrent limits.

I even would've expected that torrent #2 is capped at 50kB/s, making it a total of 65kB/s, but that is not the case.

Change History (4)

comment:1 Changed 12 years ago by charles

KyleK: I can't reproduce this. How are you adding the torrents and setting the limits: transmission-remote, or the web ui, or...?

comment:2 Changed 12 years ago by KyleK

Since neither the web UI nor the remote can set per-torrent limits I fixed up a little Ruby script that sends JSON commands via HTTP. I first do a "torrent-get" to get torrent IDs, then a "torrent-set" with the arguments { "speed-limit-up-enabled" : 1, "speed-limit-up" : 15 } for up limits. Transmission responds with { "result": success }, and a subsequent "torrent-get" confirms the changes.

I tried to reproduce this just now but that didn't work for some reason. I'll let you know if it happens again, and will hopefully be able to provide more information.

comment:3 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Please reopen this ticket if/when it happens again. :)

comment:4 Changed 12 years ago by KyleK

I think the tickets #1567 and #1569 might have been responsible for this.

Note: See TracTickets for help on using tickets.