Opened 12 years ago

Closed 12 years ago

#1572 closed Bug (duplicate)

Transmission stores filenames on target fs in wrong encoding

Reported by: spry Owned by: charles
Priority: High Milestone: None Set
Component: libtransmission Version: 1.41
Severity: Normal Keywords: patch-needed
Cc:

Description

For example, my system uses koi8r coding for filenames, as a main locale. But transmission stores files on FS in utf8 encoding. So all the names that are not latin symbolled, became unreadable.

Change History (7)

comment:1 Changed 12 years ago by spry

Have you researched anything?

comment:2 Changed 12 years ago by spry

Maybe we could use something like "user locale" on UNIX-like systems? With ability to override it via settings? For Win-systems, if we are storing anything to NTFS, it supports Unicode(UTF-16 as described in documentation), also Unicode names can be stored in FAT fs, according to MSDN. For unix-like systems.. I don't know even what to suggest.

comment:3 Changed 12 years ago by spry

Really, could we make something like "use user locale" if not overriden by config?

comment:4 Changed 12 years ago by charles

  • Keywords patch-wanted added

comment:5 Changed 12 years ago by charles

  • Keywords patch-needed added; encoding patch-wanted removed

comment:6 Changed 12 years ago by charles

http://libtorrent.rakshasa.no/ticket/1479 has an interesting discussion of a similar issue in rakshasa's libtorrent

comment:7 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #1512

Note: See TracTickets for help on using tickets.