Opened 12 years ago

Closed 12 years ago

#1574 closed Bug (invalid)

daemon can't seed: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)

Reported by: dzimi Owned by: charles
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.41
Severity: Critical Keywords:
Cc:

Description

I saw that transmission-daemon in revision 7307 can't seed. In the daemon log i saw:

[17:46:11.988] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:12.149] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: flushing outMessages... to 0x80cd728 (length is 86) (peer-msgs.c:1759)
[17:46:12.149] 91.121.201.155:45900 adding 86 bytes into io->output (peer-io.c:625)
[17:46:12.149] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:12.401] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:12.653] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:12.905] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:13.157] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:13.409] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:13.661] Coma-A_my.mp3 - 91.121.201.155:45900 [Transmission 1.40+]: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)
[17:46:13.897] Coma-A_my.mp3 RECONNECT peer 0 (85.11.66.73:15375) is in its grace period of 120 seconds.. (peer-mgr.c:2165)
[17:46:13.897] Coma-A_my.mp3 purging peer 91.121.201.155:11723 because its doPurge flag is set (peer-mgr.c:1993)
[17:46:13.897] Coma-A_my.mp3 reconnect pulse for [Coma-A_my.mp3]: 1 bad connections, 0 connection candidates, 2 atoms, max per pulse is 4 (peer-mgr.c:2213)


The 91.121.201.155 is my daemon IP. The port for incoming peers connections was set to 11723.

Client (in this case was transmissioncli r7307) died after he got the message:

Coma-A_my.mp3 - 91.121.201.155:11723 [Transmission 1.40+]: declining because it's a duplicate (peer-msgs.c:977)


Also, the uTorrent client can't read from the daemon.

BUT, when the cli seeds the same data - every was ok.

Change History (8)

comment:1 Changed 12 years ago by dzimi

  • Summary changed from randomize daemon can't seed: ibevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856) to daemon can't seed: libevent got an error! what=17, errno=11 (Resource temporarily unavailable) (peer-msgs.c:1856)

comment:2 Changed 12 years ago by dzimi

  • Severity changed from Normal to Critical

Ups, the same problem killed the transmissioncli from 1.34. Logs are attached.

WARN! ==

In this case (daemon + cli) I used the 1.41b2 as the daemon and 1.34 as the cli....

comment:3 Changed 12 years ago by dzimi

More info

This problem ONLY exist when you restart the daemon process. Then, the clients can't download from them and get those errors. But when I removed the config data dir - daemon worked.

I really have no idea what goes inside the transmission core... - let the core developers try to reproduce this problem.

comment:4 Changed 12 years ago by charles

To be honest I have a hard time what error is being reported here.

If I were to try to reproduce this test, what versions of Transmission would I need to run, and what would they be doing? Also, what is the error that I would encounter?

comment:5 Changed 12 years ago by charles

dzimi: okay, I think I understand what you're reporting. you're seeding with a daemon, downloading with cli, and they both get a "what=17" error from libevent.

Could you please attach txt versions of logs for a svn trunk seed + leecher that try to connect to each other, so that the timestamps will line up? (Also, can you make sure both clients' host machines' clocks are in sync with each other?)

comment:6 Changed 12 years ago by charles

dzimi: ping

comment:7 Changed 12 years ago by charles

dzimi: ping

comment:8 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

closing for lack of information. feel free to reopen.

Note: See TracTickets for help on using tickets.