Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1592 closed Bug (fixed)

file priorities are not preserved after exiting & starting a new session

Reported by: cdsmith Owned by: charles
Priority: Normal Milestone: 1.50
Component: libtransmission Version: 1.40
Severity: Major Keywords:
Cc:

Description

After upgrading to Transmission 1.40 I noticed that changing the priority of files has no effect. All files are downloaded at equal rates.

Change History (11)

comment:1 Changed 12 years ago by livings124

Can you try a nightly to see if this is fixed? (ref: #1454)

comment:2 Changed 12 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles

comment:3 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

Reopen this if the nightlies still don't work.

comment:4 Changed 12 years ago by cdsmith

This is not the same bug that is referenced. I have had that problem also but I think this is different. Prioritization is not getting reset. The other bug I think refers to the priority actually getting reset so when you check the files tab all files actually say "normal" priority and you can change them back. The bug I am experiencing does not respect priority at all. You can set it to whatever you want and even if the settings stick they all download equally. I'll try the latest nightly and see if the bug is fixed.

comment:5 Changed 12 years ago by zentralmaschine

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version changed from 1.40 to 1.42

I am experiencing the exact same problem with version 1.42 on a mac. Priority may be set but all files download equally. I remember this to be working in previous versions.

comment:6 Changed 12 years ago by zentralmaschine

  • Version changed from 1.42 to 1.40

comment:7 Changed 12 years ago by sensimilla

  • Severity changed from Normal to Major
  • Version changed from 1.40 to 1.42

This bug still exists in 1.42 and has existed since 1.40.

To clarify a bit, the problem is that file priorities are not respected after a restart.

They work fine when set until the program is restarted. The gui will show the correct priorities but they are actually ignored when it comes to downloading. All files download evenly. After a restart the file priorities have to be set and unset again to work for the current session.

This behaviour is completely consistent and reproducible. It is quite a serious bug and I have seen it mentioned a few times in the forum.

comment:8 Changed 12 years ago by livings124

  • Severity changed from Major to Normal
  • Version changed from 1.42 to 1.40

comment:9 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.50

I'm kind of surprised at this, but when testing out the scenario described by sensimilla I'm seeing the exact same behavior.

comment:10 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Summary changed from Transmission 1.40 does not respect priority to file priorities are not preserved after exiting & starting a new session

fix committed to trunk in r7683.

fix committed to 1.5x branch in r7684.

comment:11 Changed 12 years ago by charles

  • Severity changed from Normal to Major
Note: See TracTickets for help on using tickets.