Opened 12 years ago

Closed 12 years ago

#1596 closed Bug (invalid)

Unintuitive ratio after readding torrent and replacing files

Reported by: malesca Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.40
Severity: Normal Keywords:
Cc:

Description

I wanted to seed a torrent that I no longer had in Transmission. The torrent is a folder containing multiple files.

I did this by adding the torrent for download again, pausing the download, swapping the files out for the completed download I had since before and then resumed the download.

The problem is that before I paused the download, I got a few kBs downloaded (out of a total of several gigs). Now that I swapped the files and resumed, it seeds fine, but it calculates my ratio based on that tiny download. So if I downloaded 10 kB before I swapped out the files, then a setting of "seed to ratio 2.0" means it seeds until 20 kB.

It seems like it would make more sense if it used the file size instead of the downloaded amount in this case.

Not sure if this should be called a bug or just unintuitive.

Change History (1)

comment:1 Changed 12 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Download in ratio is based on 1. amount downloaded if there is any downloaded, otherwise 2. total size. This makes the most sense in the vast majority of cases, and it doesn't make sense to make exceptions with "if download size is too small" etc.

Note: See TracTickets for help on using tickets.