Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1602 closed Enhancement (fixed)

[PATCH] Internet Explorer 6 & 7 Support in WebUI

Reported by: j5osx Owned by:
Priority: Normal Milestone: 1.52
Component: Web Client Version: 1.41
Severity: Minor Keywords: ie internet-explorer
Cc:

Description

Remove the "Do Not Support" message currently shown when a user visits the WebUI using Internet Explorer. Add IE-specific CSS and Javascript to support Internet Explorer 6 & 7.

Attachments (4)

ie6.css (242 bytes) - added by j5osx 12 years ago.
Internet Explorer 6 stylesheet
ie7.css (198 bytes) - added by j5osx 12 years ago.
Internet Explorer 7 stylesheet
ie7.2.css (1.1 KB) - added by j5osx 12 years ago.
New version of IE7 stylesheet
ie6.2.css (1.8 KB) - added by j5osx 12 years ago.
New version of IE6 stylesheet

Download all attachments as: .zip

Change History (24)

Changed 12 years ago by j5osx

Internet Explorer 6 stylesheet

Changed 12 years ago by j5osx

Internet Explorer 7 stylesheet

comment:1 Changed 12 years ago by j5osx

Replace lines 22-28 of /web/javascript/transmission.js (rev 7300):

23 	                // Before we do anything, browser compatability test
24 	                if ($.browser.msie) {
25 	                        $('div.torrent_footer').hide();
26 	                        $('div#unsupported_browser').show();
27 	                        return;
28 	                }

with:

		// IE specific fixes here
		if ($.browser.msie) {
			try {
			  document.execCommand("BackgroundImageCache", false, true);
			} catch(err) {}
			$('head').append('<link media="screen" href="./stylesheets/common.css" type="text/css" rel="stylesheet" />');
			$('head').append('<link media="screen" href="./stylesheets/ie'+$.browser.version.substr(0,1)+'.css" type="text/css" rel="stylesheet" />');
			$('.dialog_container').css('height',$(window).height()+'px');
		}

comment:2 Changed 12 years ago by j5osx

Replace line 1022 of /web/javascript/transmission.js (rev 7300):

var container_top = parseInt($('#torrent_container').css('top')) + $('#torrent_filter_bar').height() + 1;

with:

var container_top = parseInt($('#torrent_container').position().top) + $('#torrent_filter_bar').height() + 1;

comment:3 Changed 12 years ago by j5osx

Optionally, replace lines 13-14 of /web/index.html (rev 6852):

		<link media="only screen and (max-device-width: 480px)" href="./stylesheets/iphone.css" type= "text/css" rel="stylesheet" />
		<link media="screen and (min-device-width: 481px)" href="./stylesheets/common.css" type="text/css" rel="stylesheet" />

with:

		<!--[if !IE]><!-->
		<link media="only screen and (max-device-width: 480px)" href="./stylesheets/iphone.css" type= "text/css" rel="stylesheet" />
		<link media="screen and (min-device-width: 481px)" href="./stylesheets/common.css" type="text/css" rel="stylesheet" />
		<!--<![endif]-->

comment:4 Changed 12 years ago by j5osx

Place ie6.css and ie7.css in /web/stylesheets

comment:5 Changed 12 years ago by j5osx

  • Owner j5osx deleted

comment:6 Changed 12 years ago by j5osx

  • Summary changed from Internet Explorer 6 & 7 Support in WebUI to [PATCH] Internet Explorer 6 & 7 Support in WebUI

comment:7 Changed 12 years ago by livings124

  • Milestone changed from None Set to 1.51
  • Resolution set to fixed
  • Status changed from new to closed

trunk: r7922 1.5x: r7923

comment:8 Changed 12 years ago by livings124

  • Severity changed from Trivial to Normal

comment:9 Changed 12 years ago by livings124

  • Priority changed from Low to Normal

comment:10 Changed 12 years ago by KyleK

  • Resolution fixed deleted
  • Severity changed from Normal to Minor
  • Status changed from closed to reopened

A NAS user tells me that with Transmission 1.51 the Web interface doesn't work with Opera anymore. I suspect this patch to be the culprit.

I don't use Opera so I can't confirm, just wanted to let you guys know.

comment:12 Changed 12 years ago by j5osx

  • Resolution set to fixed
  • Status changed from reopened to closed

Underlying jquery / jquery dimensions plugin is the real culprit (.position().top not working in Opera) but a workaround without upgrading the jquery version / dimensions plugin is to replace the existing showFilter function with this:

	showFilter: function( ) {
		var container_top;
		try {
		    container_top = parseInt($('#torrent_container').position().top) + $('#torrent_filter_bar').height() + 1;
		} catch (e) {
			container_top = parseInt($('#torrent_container').css("top")) + $('#torrent_filter_bar').height() + 1;
		}
		$('#torrent_container').css('top', container_top + 'px');
		$('#torrent_filter_bar').show();
		this.setPref( Prefs._ShowFilter, true );
	},

comment:13 Changed 12 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:14 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in trunk for 1.60 in r8000 and r8002.

Fixed in 1.5x branch for a possible 1.52 in r8030.

comment:15 Changed 12 years ago by charles

  • Milestone changed from 1.51 to 1.52

comment:16 Changed 12 years ago by charles

http://forum.transmissionbt.com/viewtopic.php?f=8&t=7193&p=35322#p35322 says:

Charles, testing 8407 OS X nightly and IE 7 support is broken. The issue is that the dimensions plugin is now part of jQuery core and should not be included. Including it is overwriting the core integrated functions with old incompatible versions.

Simply commenting out the incompatible versions is fixing IE7 basic display in my sanity check tests. Opera 9.5 OS X is also working as far as a quick sanity check. of the display of the torrent list and no errors thrown.

Fixed in trunk in r8050

Fixed in the 1.5x branch in r8051

Changed 12 years ago by j5osx

New version of IE7 stylesheet

Changed 12 years ago by j5osx

New version of IE6 stylesheet

comment:17 Changed 12 years ago by j5osx

  • Resolution fixed deleted
  • Status changed from closed to reopened

Added new versions of IE 6 and IE 7 stylesheets to fix some of the known issues.

comment:18 Changed 12 years ago by livings124

  • Milestone changed from 1.52 to 1.60

trunk: r8055

comment:19 Changed 12 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:20 Changed 12 years ago by charles

  • Milestone changed from 1.60 to 1.52

1.5x: r8056

Note: See TracTickets for help on using tickets.