Opened 12 years ago

Closed 12 years ago

#1625 closed Bug (fixed)

segmentation fault when clicking on Edit> preferences on transmission 1.41~b5 on Ubuntu Intrepid

Reported by: shirish Owned by: charles
Priority: Normal Milestone:
Component: GTK+ Client Version: 1.41
Severity: Normal Keywords: segfault, preferences
Cc:

Description

Hi all,

Would be attaching a debug of a seg fault happening while running transmission 1.41~b5 on Ubuntu Intrepid

Attachments (1)

gdb-transmission.txt (23.3 KB) - added by shirish 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by shirish

comment:1 Changed 12 years ago by shirish

  • Keywords segfault preferences added
  • Summary changed from segmentation fault while running transmission 1.41~b5 on Ubuntu Intrepid to segmentation fault when clicking on Edit> preferences on transmission 1.41~b5 on Ubuntu Intrepid

comment:2 Changed 12 years ago by charles

I can't reproduce this on Fedora 10.

  • what is your locale set to?
  • does this happen every time you open the preferences dialog?

comment:3 Changed 12 years ago by shirish

how do I know what is my locale is set to?

Yes, this happens every time I try to open the preferences dialog.

comment:4 Changed 12 years ago by shirish

perhaps this is what you are looking for

~$ locale LANG=en_IN LC_CTYPE="en_IN" LC_NUMERIC="en_IN" LC_TIME="en_IN" LC_COLLATE="en_IN" LC_MONETARY="en_IN" LC_MESSAGES="en_IN" LC_PAPER="en_IN" LC_NAME="en_IN" LC_ADDRESS="en_IN" LC_TELEPHONE="en_IN" LC_MEASUREMENT="en_IN" LC_IDENTIFICATION="en_IN" LC_ALL=

comment:5 Changed 12 years ago by charles

  • Component changed from Transmission to GTK+ Client
  • Milestone None Set deleted
  • Owner set to charles
  • Status changed from new to assigned

Yep, when I set that locale I get the crash too.

comment:6 Changed 12 years ago by charles

Looks like this is because we're using %X in strftime for ticket #1588, and this locale is treating it oddly.

comment:7 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Changed to %H:%M in r7478 (1.4x) and r7477 (trunk).

Note: See TracTickets for help on using tickets.