Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1639 closed Bug (fixed)

Transmission quits when disk is full

Reported by: soyer Owned by: charles
Priority: Normal Milestone: 1.50
Component: Transmission Version: 1.42
Severity: Major Keywords:
Cc:

Description

# dmesg |tail
pid 2819 (transmission-daemon), uid 1001 inumber 5793901 on /usr/home/os: filesystem full
pid 2805 (transmission-daemon), uid 1001 inumber 3 on /usr/home/os: filesystem full
pid 2805 (transmission-daemon), uid 1001: exited on signal 6
pid 2819 (transmission-daemon), uid 1001: exited on signal 6
pid 2812 (transmission-daemon), uid 1001 inumber 1295385 on /usr/home/os: filesystem full
pid 2812 (transmission-daemon), uid 1001 inumber 3 on /usr/home/os: filesystem full
pid 2812 (transmission-daemon), uid 1001: exited on signal 6

Attachments (1)

gtk-disk-full-screenshot-r7603.png (26.5 KB) - added by charles 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by charles

  • Milestone 1.43 deleted

comment:2 Changed 12 years ago by MighMoS

Is this just the daemon or the underlying library? The transmission-gtk client just crashed on me when the disk was full and took about 1GB worth of download with it (which I have to fetch, once again).

comment:3 Changed 12 years ago by spry

  • Priority changed from Normal to High

Confirmed.

pid 1379 (transmission-daemon), uid 1005 inumber 47575092 on /storage/storage1: filesystem full
pid 1379 (transmission-daemon), uid 1005: exited on signal 6 (core dumped)

In earlier releases, all torrents got paused if there no space left.

comment:4 Changed 12 years ago by charles

wrt the gtk client, I'm not seeing this behavior in r7603. The torrent gives the error "No space left on device" and pauses itself.

Attaching screenshot

Changed 12 years ago by charles

comment:5 Changed 12 years ago by charles

I can't reproduce this in the daemon either.

daemon:

$ export TRANSMISSION_HOME=/tmp/test
$ grep download-dir $TRANSMISSION_HOME/settings.json
    "download-dir": "\/media\/D2",
$ df -h | grep D2 
/dev/sdb               16G   16G  345M  98% /media/D2
$ ./transmission-daemon -f 
Transmission 1.42+ (7645) started

remote:

$ ./transmission-remote -a ~/Desktop/*darwin.torrent
$ ./transmission-remote -l 
ID    Done  ETA       Up      Down    Ratio  Status       Name
   1    0%  2 days       0.0     3.6   0.00  Downloading  Librivox - On the Origin of Species by Means of Natural Selection - Charles Darwin
$ ./transmission-remote -l 
ID    Done  ETA       Up      Down    Ratio  Status       Name
   1    0%  2 hrs        0.0    67.6   0.00  Downloading  Librivox - On the Origin of Species by Means of Natural Selection - Charles Darwin
$ ./transmission-remote -l 
ID    Done  ETA       Up      Down    Ratio  Status       Name
   1    0%  29 min       0.0   386.9   0.00  Downloading  Librivox - On the Origin of Species by Means of Natural Selection - Charles Darwin
$ ./transmission-remote -l 
ID    Done  ETA       Up      Down    Ratio  Status       Name
   1    0%  Unknown      0.0   891.6   0.00  Stopped      Librivox - On the Origin of Species by Means of Natural Selection - Charles Darwin
$ df -h | grep D2 
/dev/sdb               16G   16G     0 100% /media/D2
$ ps -ef | grep transmission-daemon 
charles  15800 32578  0 14:27 pts/13   00:00:01 ./transmission-daemon -f
charles  15880 15558  0 14:31 pts/14   00:00:00 grep transmission-daemon

comment:6 Changed 12 years ago by charles

  • Milestone set to 1.50
  • Status changed from new to assigned

Spry, soyer, can you please try with a trunk build of the daemon and see what you get?

Since it's worked in two tests for me in trunk I'm going to close this ticket as `fixed' for now but please do reopen if there is still a problem that I'm not seeing.

comment:7 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:8 Changed 12 years ago by spry

Confirmed, trunk works ok.

comment:9 Changed 12 years ago by charles

  • Component changed from Daemon to Transmission
  • Summary changed from daemon quits, when disk is full to Transmission quits when disk is full

comment:10 Changed 12 years ago by charles

  • Severity changed from Normal to Major

comment:11 Changed 12 years ago by charles

  • Priority changed from High to Normal
Note: See TracTickets for help on using tickets.