Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1648 closed Bug (duplicate)

Transmission Constantly Shuts Down

Reported by: Suna Shiro Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.42
Severity: Major Keywords:
Cc:

Description

Every time I boot up transmission it will open for about 5 seconds and shut down, this only started happening after I upgraded to the new version I tried down grading and it doesn't work oddly enough another user on my computer can use transmission without a problem. If it helps I do have the report that the computer gave me as to why it shut down and can give that to you at your request also I am using Mac OS X 10.5. Thanks for your help, Suna Shiro

Attachments (1)

Transmission Report.rtf (22.7 KB) - added by Suna Shiro 12 years ago.
Transmission Failure Report

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by livings124

Post the report and anything written in the Console (in Applications/Utilities?) from Transmission.

Changed 12 years ago by Suna Shiro

Transmission Failure Report

comment:2 Changed 12 years ago by Suna Shiro

I just uploaded a text file with all the information that it gave me and what the console had on it. Thanks so much for your help. ~Suna Shiro

comment:3 follow-ups: Changed 12 years ago by charles

Money shot from "Transmission Report.rtf":

Process:         Transmission [5930]
Path:            /Applications/Transmission.app/Contents/MacOS/Transmission
Identifier:      org.m0k.transmission
Version:         1.42 (7494)
Code Type:       X86 (Native)
Parent Process:  launchd [124]

Thread 1 Crashed:
0   libSystem.B.dylib             	0x9142ddbe __semwait_signal_nocancel + 10
1   libSystem.B.dylib             	0x9141fc87 usleep$NOCANCEL$UNIX2003 + 61
2   libSystem.B.dylib             	0x9144148b abort + 85
3   org.m0k.transmission          	0x0008b5a4 0x1000 + 566692
4   org.m0k.transmission          	0x0007e14b 0x1000 + 512331
5   org.m0k.transmission          	0x0006b0ae 0x1000 + 434350
6   org.m0k.transmission          	0x00082232 0x1000 + 528946
7   org.m0k.transmission          	0x0008264e 0x1000 + 529998
8   org.m0k.transmission          	0x0006659b 0x1000 + 415131
9   libSystem.B.dylib             	0x9137d6f5 _pthread_start + 321
10  libSystem.B.dylib             	0x9137d5b2 thread_start + 34

This looks like an assertion failure to me.

Suna Shiro: Could you please check in Console.app, under LOG DATABASE QUERIES > Console Messages, search for Transmission, and look for message(s) that mention assertion failures? If you find any, please add them here in a comment.

comment:4 in reply to: ↑ 3 Changed 12 years ago by Suna Shiro

12/31/08 1:28:51 PM [0x0-0x5f05f].org.m0k.transmission[6707] /Users/mitchell/Desktop/Transmission_1.4x/libtransmission/bandwidth.c:428: failed assertion `tr_isBandwidth( b )'

You were absolutely right, not that I know what an assertion failure is but if you know what it is it can't be that bad, or its fatal... Well I'll be praying. lol

comment:5 Changed 12 years ago by Suna Shiro

Oh, and I just received a software update from apple. Installing that now wont mess with anything you're going to have me do will it?

comment:6 follow-up: Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1632. Thanks for the report!

comment:7 in reply to: ↑ 6 Changed 12 years ago by Suna Shiro

Replying to livings124:

This is a duplicate of #1632. Thanks for the report!

Soooo... wait what do I do? I read #1632 but I'm not quite understand what my next move is here.

comment:8 Changed 12 years ago by livings124

Wait for it to be fixed on our end. ;)

comment:9 Changed 12 years ago by livings124

Or try the latest from http://transmission.xpjets.com/ and let us know if it works or not.

comment:10 in reply to: ↑ 3 Changed 12 years ago by Suna Shiro

The link you sent to me also did not work I tried the latest version below is what happened.

The Console said:

12/31/08 2:53:20 PM [0x0-0x72072].org.m0k.transmission[9658] Assertion failed: (EVBUFFER_LENGTH( inbuf ) == startBufLen - msglen - 1), function readBtMessage, file /var/tmp/pea/svn.transmissionbt.com/trunk/libtransmission/peer-msgs.c, line 1578.

comment:11 Changed 12 years ago by livings124

Is that still happening in the latest nightly from that link?

Note: See TracTickets for help on using tickets.