Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1660 closed Bug (fixed)

Assertion failed: (tr_isBandwidth( b ))

Reported by: Biiaru Owned by: charles
Priority: Normal Milestone: 1.50
Component: libtransmission Version: 1.42
Severity: Critical Keywords:
Cc: transmission+1660@…

Description

This has happened for as long as I can remember, and I have no idea why. Not exclusive to recent versions, this goes back a while.

Attachments (1)

Transmission_2009-01-05-173452_Winter.crash (26.6 KB) - added by Biiaru 12 years ago.
Crash report.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by Biiaru

Crash report.

comment:1 Changed 12 years ago by Biiaru

  • Cc transmission+1660@… added

comment:2 Changed 12 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles

Is there an assert message that goes with this?

comment:3 Changed 12 years ago by Biiaru

Yes: 1/5/09 5:34:51 PM [0x0-0x154154].org.m0k.transmission[7061] Assertion failed: (tr_isBandwidth( b )), function tr_bandwidthClamp, file /var/tmp/pea/svn.transmissionbt.com/trunk/libtransmission/bandwidth.c, line 277.

comment:4 Changed 12 years ago by livings124

  • Summary changed from Transmission always crashes on quit to Assertion failed: (tr_isBandwidth( b ))

comment:5 Changed 12 years ago by charles

  • Status changed from new to assigned

Fixed in r7623

comment:6 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.43
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version changed from 1.42+ to 1.42

comment:7 Changed 12 years ago by charles

Ticket #1678 has been marked as a duplicate of this ticket.

comment:8 Changed 12 years ago by charles

  • Milestone changed from 1.43 to 1.50

comment:9 Changed 12 years ago by charles

  • Severity changed from Normal to Major

comment:10 Changed 12 years ago by charles

  • Severity changed from Major to Critical

(Note: this is the same assertion error as #1632, but it's caused by a different bug.)

Note: See TracTickets for help on using tickets.