Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#1663 closed Bug (fixed)

Crashes on shutdown if libevent loop doesn't exit soon enough

Reported by: Biiaru Owned by: charles
Priority: Normal Milestone: 1.77
Component: libtransmission Version: 1.42
Severity: Major Keywords:
Cc:

Description

1/5/09 8:45:59 PM [0x0-0x1f41f4].org.m0k.transmission[8887] Assertion failed: (l->depth >= 0), function tr_lockLock, file /Users/nadare/Code/Transmission/libtransmission/platform.c, line 191.

Build 7624.

Attachments (3)

Transmission_2009-01-05-204601_Winter.crash (28.2 KB) - added by Biiaru 12 years ago.
Crash report.
Transmission_2009-02-09-151651_Winter.crash (27.1 KB) - added by Biiaru 12 years ago.
still present in r7845: 2/9/09 3:16:51 PM [0x0-0x28b28b].org.m0k.transmission[64098] Assertion failed: (l->depth > 0), function tr_lockUnlock, file /Users/nadare/Transmission/libtransmission/platform.c, line 208.
TransmissionCrash.txt (34.4 KB) - added by mortennorby 11 years ago.
A crash log of a similar situation

Download all attachments as: .zip

Change History (23)

Changed 12 years ago by Biiaru

Crash report.

comment:1 Changed 12 years ago by charles

This is during shutdown, correct?

comment:2 Changed 12 years ago by Biiaru

Yes.

comment:3 Changed 12 years ago by charles

  • Summary changed from Assertion failed: (l->depth >= 0), function tr_lockLock to Assertion failed on shutdown: (l->depth >= 0), function tr_lockLock

comment:4 Changed 12 years ago by charles

  • Status changed from new to assigned
  • Summary changed from Assertion failed on shutdown: (l->depth >= 0), function tr_lockLock to Crashes on shutdown if libevent loop doesn't exit soon enough
  • Version changed from 1.42+ to 1.42

#1779 is a variation on this, but caused by the same root cause

Changed 12 years ago by Biiaru

still present in r7845: 2/9/09 3:16:51 PM [0x0-0x28b28b].org.m0k.transmission[64098] Assertion failed: (l->depth > 0), function tr_lockUnlock, file /Users/nadare/Transmission/libtransmission/platform.c, line 208.

comment:5 Changed 12 years ago by livings124

#1934 looks related to this.

comment:6 Changed 12 years ago by charles

#1960 has been marked as a duplicate of this ticket.

comment:7 Changed 12 years ago by charles

#2074 has been marked as a duplicate of this ticket.

comment:8 Changed 11 years ago by charles

#2163 has been marked as a duplicate of this ticket.

comment:9 Changed 11 years ago by livings124

Another crash:http://transmission.pastebin.com/f1ead5277

comment:10 Changed 11 years ago by livings124

  • Severity changed from Normal to Major

I've noticed an increase of this problem since DHT has been added.

comment:11 Changed 11 years ago by Biiaru

Well, I don't have DHT enabled at all, so I don't think that's the major reason it happens. (Or do you mean just DHT support, not necessarily enabled?)

comment:12 Changed 11 years ago by livings124

I mean that since DHT has been added, it seems to happen more (I do have DHT enabled). Who knows, it could be completely unrelated.

comment:13 Changed 11 years ago by charles

#2314 has been marked as a duplicate of this ticket.

Changed 11 years ago by mortennorby

A crash log of a similar situation

comment:14 Changed 11 years ago by charles

Ticket #2047 has been closed as a duplicate of this ticket.

comment:15 Changed 11 years ago by charles

charles * r9642 /trunk/ (gtk/main.c libtransmission/session.c): (trunk) #1663 "crashes on shutdown if libevent loop doesn't exit soon enough" -- maybe crash less frequently now.

comment:16 Changed 11 years ago by charles

At least one user reports that this solves the problem: http://forum.transmissionbt.com/viewtopic.php?p=42389#p42389

comment:18 Changed 11 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:19 Changed 11 years ago by charles

  • Milestone changed from None Set to 1.80

comment:20 Changed 11 years ago by charles

  • Milestone changed from 1.80 to 1.77

backported to 1.7x for 1.77 by r9880

Note: See TracTickets for help on using tickets.