Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1667 closed Bug (worksforme)

Display getting cropped to the right on Tiger

Reported by: tgos Owned by: livings124
Priority: Normal Milestone:
Component: Mac Client Version: 1.42
Severity: Normal Keywords:
Cc:

Description

If this is a duplicate, I'm sorry, but I have not found any ticket for that. On my Mac (10.4) I often see the issue that the display is cropped to the right. That means the progress bars go beyond the right window border and I cannot see the pause or reveal buttons. Sometimes pausing one download and resuming it fixes the issue, but not always. Usually the problem occurs directly after starting the client, it won't happen once the client is already running and the display is correct. I'll post a screenshot to show the problem. Usually I have this problem if I have so many torrents running that the right scrollbar is shown. There never is a scrollbar shown an the window button, thus I cannot even get to the cropped part by scrolling.

Attachments (1)

Picture 1.png (27.3 KB) - added by tgos 12 years ago.
Screenshot illustrating the problem

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by tgos

Screenshot illustrating the problem

comment:1 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

This issue only occurs on Tiger 10.4. Since Transmission 1.5 will require Leopard 10.5, this is a non-issue.

comment:2 Changed 12 years ago by tgos

IOW I have to upgrade my operating system for over 100 bucks to get an error-free Transmission (or at least one you can work with)? Time to switch to another P2P client, I guess.

BTW, how do you know it only occurs on Tiger? If it is a duplicate of a known issue, you should close it as duplicate and not as wontfix. If it is no duplicate, the issue is unknown and without analyzing what is actually causing the issue in the first place, how can you make an assumption like that?

comment:3 Changed 12 years ago by livings124

This is a known issue that is Tiger-only. I'm not sure if there was a ticket - feel free to hunt it down and change the reason for closing..

Transmission is a free application written by the developers on their free time. Dropping 10.4 support allows for new features to be added that require 10.5 functionality; it also makes development a lot easier in general. Leopard has been out for over a year (1.5 years by the time Transmission 1.5 is out) - Apple already requires it for many of their apps such as iLife and iWork.

If you can come up with a fix for this issue on 10.4 feel free. The code is available and I would gladly add it to a 1.4 point release.

comment:4 Changed 12 years ago by Robby

Yep, this is an annoying problem in 1.4x that is there everytime I launch T. A workaround is to click the green button twice.
Please re-open. This is a valid problem, at least for 1.4x.

comment:5 Changed 12 years ago by livings124

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Can those with issues try http://files.me.com/livings124/hki3qg

comment:6 Changed 12 years ago by livings124

comment:7 Changed 12 years ago by livings124

Rolcol confirms that this is fixed, but I would like more feedback.

comment:8 Changed 12 years ago by Robby

It is fixed in that last build, yes. :)

comment:9 Changed 12 years ago by livings124

  • Milestone changed from None Set to 1.51
  • Resolution set to fixed
  • Status changed from reopened to closed

comment:10 Changed 12 years ago by Rolcol

I don't have Tiger... You may have mistaken me for someone else. If I said something by accident that made it seem like I tested it, I'm sorry but I haven't.

comment:11 Changed 12 years ago by livings124

Whoops, it was rob-to86.

comment:12 Changed 12 years ago by livings124

  • Summary changed from Display getting cropped to the right to Display getting cropped to the right on Tiger

comment:13 Changed 12 years ago by livings124

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:14 Changed 12 years ago by livings124

  • Milestone 1.51 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

The reports on the forums have been mixed. Let's err on the side of caution and not mark as fixed for now.

comment:15 Changed 12 years ago by tgos

Since the latest update the problems does not always occur, but still pretty often. Best known work around when it happens: Making the filter bar displayed and switching between the different categories there before switching back to "all" and it is displayed correctly again. As a Mac developer I doubt that this is a bug in the OS. I don't know of any other application that has this issue, nor have I ever had to code around a comparable issue in any of my applications.

Note: See TracTickets for help on using tickets.