Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1670 closed Bug (fixed)

r7632 crash on start: Assertion failed: (tr_isPeerIo( io ))

Reported by: Biiaru Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.42
Severity: Normal Keywords:
Cc:

Description

1/7/09 11:09:01 AM [0x0-0x162162].org.m0k.transmission[2475] Assertion failed: (tr_isPeerIo( io )), function event_read_cb, file /var/tmp/pea/svn.transmissionbt.com/trunk/libtransmission/peer-io.c, line 196.

Build 7632. No idea if this is exclusive to this version.

Attachments (2)

Transmission_2009-01-07-110901_Winter.crash (20.3 KB) - added by Biiaru 12 years ago.
Crash report.
Transmission_2009-01-07-111334_Winter.crash (20.0 KB) - added by Biiaru 12 years ago.
Another similar crash report.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by Biiaru

Crash report.

Changed 12 years ago by Biiaru

Another similar crash report.

comment:1 Changed 12 years ago by Biiaru

For the second crash report, there was no assert, only this:

1/7/09 11:13:54 AM com.apple.launchd[154] ([0x0-0x168168].org.m0k.transmission[2517]) Exited abnormally: Segmentation fault

comment:2 Changed 12 years ago by Biiaru

Will keep trying to start and see if I get any different crashes. (Don't worry, I have my save data backed up :))

comment:3 Changed 12 years ago by charles

I can't reproduce this. Is this still happening for you?

comment:4 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

please reopen this ticket if the problem persists in 1.50 beta 1

comment:5 Changed 12 years ago by charles

A note about marking that ticket as "fixed" instead of "worksforme" or "invalid": there were quite a few assertion failures for tr_isPeerIo() a week or so ago, and all the known ones have been fixed. Though there's not enough information to be sure, I'm working from the assumption that this is one of the fixed ones. If this is incorrect, that's fine, just reopen the ticket :)

Note: See TracTickets for help on using tickets.