Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1676 closed Bug (invalid)

Transmission 1.42 (7495) crash in Ubuntu 8.04

Reported by: oleg Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 1.42
Severity: Normal Keywords: crash ubuntu gtk
Cc:

Description

I am using latest available transmission binaries from http://ppa.launchpad.net/transmissionbt/ubuntu

How to reproduce: rename directory (actually I've changed drive mount point) with torrents (seeding all of these torrents) and restarted transmission. Some torrents were paused.

Configuration:

  • Transmission 1.42 (7495)
  • Ubuntu desktop 8.04, russian localization

Here is the gdb output:

***@***:~$ gdb transmission
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
(no debugging symbols found)
(gdb) handle SIGSEGV nostop
Signal        Stop	Print	Pass to program	Description
SIGSEGV       No	Yes	Yes		Segmentation fault
(gdb) run
Starting program: /usr/bin/transmission 
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 0xb6f11ac0 (LWP 6628)]
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
[New Thread 0xb67f4b90 (LWP 6632)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGPIPE, Broken pipe.
[Switching to Thread 0xb67f4b90 (LWP 6632)]
---Type <return> to continue, or q <return> to quit---
0xb7f51410 in __kernel_vsyscall ()
(gdb) bt full
#0  0xb7f51410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb772391b in write () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2  0x080a4be4 in ?? ()
No symbol table info available.
#3  0x080a4e18 in tr_peerIoFlush ()
No symbol table info available.
#4  0x0809b47b in tr_bandwidthAllocate ()
No symbol table info available.
#5  0x080a673c in ?? ()
No symbol table info available.
#6  0x08096bf8 in ?? ()
No symbol table info available.
#7  0x080c76c3 in event_base_loop ()
No symbol table info available.
#8  0x080c79ea in event_loop ()
No symbol table info available.
#9  0x080c7a02 in event_dispatch ()
No symbol table info available.
#10 0x08096808 in ?? ()
No symbol table info available.
#11 0xb771c4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#12 0xb769ee5e in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
(gdb) quit
The program is running.  Exit anyway? (y or n) y
***@***:~$ 

Please contact me if you need more details.

Best regards, Oleg Yaroshevych.

Change History (4)

comment:1 Changed 12 years ago by oleg

  • Component changed from Transmission to GTK+ Client
  • Owner set to charles

comment:2 Changed 12 years ago by charles

Thank you for your backtrace, but unfortunately it doesn't provide much information. If you'd like to run another gdb session, there are a couple of things that can make it more useful:

  • That was a stripped version of transmission, so no debugging symbols are found. Installing transmission-debug should solve that.
  • gdb needs to be told to ignore SIGPIPE. For some reason if an application explicitly ignores SIGPIPE, gdb will un-ignore it. That SIGPIPE is an artifact of using gdb, and unfortunately it stopped things before the real crash was reached.

Lastly, if you're feeling brave you should try using the Ubuntu nightly. A lot of code has changed since 1.42.

comment:3 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket as incomplete; please reopen when more information is available.

comment:4 Changed 12 years ago by oleg

Hello,

I've tested Transmission from beta and nightly repos. It works fine now. Looks like problem was solved in the peer-io.c

Problem appeared when program tried to download files in the folder without appropriate permissions. Now application displays "No such file or directory" for these torrents.

Best regards, Oleg Yaroshevych.

Note: See TracTickets for help on using tickets.