Opened 13 years ago

Closed 13 years ago

#1684 closed Bug (fixed)

Crash when downloading a file that's got the same name as an existing directory

Reported by: past Owned by:
Priority: High Milestone: None Set
Component: Transmission Version: 1.42
Severity: Major Keywords:
Cc:

Description (last modified by charles)

transmission crashing if file in torrent have same name as already existing directory:

filename.avi: Got 9 peers from tracker Couldn't open "/share/Download/filename.avi": Is a directory Killed

Attachments (1)

file-is-a-directory.png (26.2 KB) - added by charles 13 years ago.
downloading a file which has the same name as an existing directory in Transmission 1.50 beta 1, gtk+ client

Download all attachments as: .zip

Change History (3)

comment:1 Changed 13 years ago by charles

  • Description modified (diff)
  • Summary changed from 1.42 crash to Crash when downloading a file that's got the same name as an existing directory

comment:2 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this in 1.50. When I tried it, the torrent's status message flipped to red and said "Is a Directory", then stopped the torrent, which IMO is a reasonable way to handle the error.

Attached is a screenshot.

If you have further problems with this in the 1.50 beta, please reopen this ticket.

Changed 13 years ago by charles

downloading a file which has the same name as an existing directory in Transmission 1.50 beta 1, gtk+ client

Note: See TracTickets for help on using tickets.