Opened 12 years ago

Closed 11 years ago

#1701 closed Bug (worksforme)

Auto add doesn't work with Smart Folders

Reported by: Sesquipedalian Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.42
Severity: Normal Keywords:
Cc:

Description

The auto add feature allows me to select a Smart Folder to watch. However, when I download a torrent that matches the Smart Folder (I have the Smart Folder set to show all torrent files on a particular volume), Transmission does not automatically add the torrent. The torrent file does appear in the Smart Folder when opened in Finder, but Transmission ignores it.

Change History (3)

comment:1 Changed 12 years ago by Sesquipedalian

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 12 years ago by livings124

I have confirmed with an Apple developer that there is a bug in the OS that allows Smart Folders to be selected in open dialogs. I'll leave this open until either Apple fixes it or I update the app to ignore Smart Folder.

The ability to use smart folders with auto-add isn't possible because of the underlying way this is implemented.

comment:3 Changed 11 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

I have just received an email from Apple saying this is fixed in 10.6. I have verified that this does seem to be the case. Marking as "works for me" - that seems like the best choice.

Note: See TracTickets for help on using tickets.