Opened 12 years ago

Closed 12 years ago

#1733 closed Bug (fixed)

r7768 Assertion failed: (tr_isPeerIo( io )), function event_write_cb

Reported by: Biiaru Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.42+
Severity: Normal Keywords:
Cc:

Description

Crashes on startup.

1/21/09 10:41:21 PM [0x0-0x1a11a1].org.m0k.transmission[96851] Assertion failed: (tr_isPeerIo( io )), function event_write_cb, file /var/tmp/pea/svn.transmissionbt.com/trunk/libtransmission/peer-io.c, line 273.

Attachments (8)

Transmission_2009-01-21-224121_Winter.crash (20.4 KB) - added by Biiaru 12 years ago.
Transmission_2009-01-23-195326_Winter.crash (20.7 KB) - added by Biiaru 12 years ago.
r7784 crash on start with same assert
Transmission_2009-01-23-204240_Winter.crash (24.4 KB) - added by Biiaru 12 years ago.
another in 7784, crash on start, same assert
Transmission_2009-01-23-205520_Winter.crash (39.2 KB) - added by Biiaru 12 years ago.
yet another, 7784, crash on start. though each time the crash report looks way different! always the same assert, though…
Transmission_2009-01-23-214316_Winter.crash (55.2 KB) - added by Biiaru 12 years ago.
7784 crash on start, why the heck are these different every time? (thread 1 is way different than on the other ones...)
Transmission_2009-01-24-014702_Winter.crash (21.3 KB) - added by Biiaru 12 years ago.
NOT a crash on start, 7789. Ran for a good hour or two before dying.
Transmission_2009-01-24-104247_Winter.crash (64.2 KB) - added by Biiaru 12 years ago.
not crash on start, 7790. same assert.
Transmission_2009-01-24-104841_Winter.crash (20.1 KB) - added by Biiaru 12 years ago.
crash on start, 7790, same assert

Download all attachments as: .zip

Change History (18)

comment:1 Changed 12 years ago by charles

I can't reproduce this or its sibling #1730. Is this happening frequently for you? Do you have any suggestions on how I can trigger it?

comment:2 Changed 12 years ago by Biiaru

It only happened once for me on startup, but I regularly get this or similar during the run of the application. Most of the time it'll only stay open 10-20 minutes or so.

On how to trigger it? Not sure, though I figure the problem has something to do with the extreme number of torrents I have in T... try loading about 1650 torrents in or so and see if you can reproduce.

Changed 12 years ago by Biiaru

r7784 crash on start with same assert

Changed 12 years ago by Biiaru

another in 7784, crash on start, same assert

comment:3 Changed 12 years ago by Biiaru

This is now happening every time I start Transmission as of r7784. (Though it may not be due to that specific revision, I just grabbed the latest one today to try and test it)

Changed 12 years ago by Biiaru

yet another, 7784, crash on start. though each time the crash report looks way different! always the same assert, though...

Changed 12 years ago by Biiaru

7784 crash on start, why the heck are these different every time? (thread 1 is way different than on the other ones...)

comment:4 Changed 12 years ago by Biiaru

Upgrading to 7787, will see if it makes a difference.

comment:5 Changed 12 years ago by Biiaru

7787 has different assert on crash, filing new bug.

comment:6 Changed 12 years ago by Biiaru

This is possibly due to an Input Manager. Once I confirm that it is, and once I figure out which one was doing it, I'll close the ticket and provide more information.

comment:7 Changed 12 years ago by Biiaru

Transmission was able to start up with all of my Input Managers removed. However, during application run time (about an hour or so after it started) it crashed with the same assert and a similar crash report to one already posted. So I don't know what it has to do with Input Managers at all anymore...

comment:8 Changed 12 years ago by livings124

As I told you repeatedly, removing Input Managers is relevant to ticket #1744.

Changed 12 years ago by Biiaru

NOT a crash on start, 7789. Ran for a good hour or two before dying.

Changed 12 years ago by Biiaru

not crash on start, 7790. same assert.

Changed 12 years ago by Biiaru

crash on start, 7790, same assert

comment:9 Changed 12 years ago by charles

Please let me know if this persists in r7793 or higher.

comment:10 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

According to Biiaru in #transmission, this stopped occurring in r7790

Note: See TracTickets for help on using tickets.