Opened 12 years ago

Closed 12 years ago

#1746 closed Bug (invalid)

Not properly deleting torrents - last one deleted re-appears when you next launch Transmission

Reported by: myxiplx Owned by: charles
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.42
Severity: Normal Keywords:
Cc:

Description

I spotted this in 1.34 as supplied with Ubuntu, and it's still present in 1.42.

If I remove an unfinished download from the program, it re-appears then next time I start Transmission. It's done this now for a couple of different downloads, regardless of whether I use 'Remove' or 'Delete files and remove'.

I first spotted it after removing a whole bunch of torrents, while most deleted fine, the last one re-appeared in the list the next time I started transmission.

It seems to do this even if you add a bunch of other torrents, so if you do this:

  • remove all torrents
  • start a couple of new downloads
  • close transmission

The next time you launch Transmission, you'll get your two new downloads, plus one of the ones you deleted.

It looks to me like it removes the files, and removes the download from the current session, but leaves it saved for transmission to start it again next time it launches.

Change History (6)

comment:1 Changed 12 years ago by smmalis

You should check the permissions of all files in ~/.config/transmission/. There are a lot of glitches in Ubuntu that remove write permission to files in your home folder (I've dealt with a few). Make sure everything has read/write permissions for you.

comment:2 Changed 12 years ago by myxiplx

Thanks, it wasn't permissions, but that helped me get to the bottom of it. It looks like I was wrong - it wasn't leaving the last file, but one particular file each time.

And when I had a look in that folder, I could see that the file appeared to be a copy of a torrent, and also was missing the .torrent extension.

After some testing, the lack of the .torrent extension doesn't cause a problem, but the " (copy)" text does. I've not checked whether it's the space or the brackets causing the problem, but if that string appears in the torrent name, transmission can't delete the file and so loads it each time.

It's easy to reproduce. Close transmission, make a copy of a file in that folder, and delete the original file. You're now left with a torrent that will re-appear on every launch, even though it appears to delete ok from the program window.

And just in case it proves hard to reproduce, in my case, I was able to reproduce this with a file named: "Ubuntu-8 (copy).10-Desktop-i386.iso.87be5bf4e11e434f.torrent"

comment:3 Changed 12 years ago by charles

  • Owner set to charles
  • Status changed from new to assigned

myxiplx: nice detective work, there. :)

comment:4 Changed 12 years ago by charles

...I can't reproduce this. I downloaded the .torrent file named "ubuntu-8.10-desktop-i386.iso.torrent", had Nautilus make a copy named "ubuntu-8 (copy).10-desktop-i386.iso.torrent", and added the copy. After doing this, the filename in my ~/.config/transmission/torrents/ directory was named "ubuntu-8.10-desktop-i386.iso.33820db6dd5e5928.torrent", and removing it worked correctly...

The only way I can find to reproduce this is by copying files by hand into ~/.config/transmission/ which is not supported behavior.

Is there some other way to trigger the behavior you're seeing?

comment:5 Changed 12 years ago by myxiplx

Hmm... well, since I didn't even know that folder existed before, I'm pretty sure I didn't add it manually ;-)

I've no idea how that file got there, but I would say the bug isn't with the file that was created, but with the fact that Transmission is able to happily open and use a file with " (copy)" in the name, but isn't able to delete it.

Sounds to me like a bug in the deletion code, which should be an easy enough fix regardless of how this occurred in the first place.

Regarding the creation of the file, I've been running standard Ubuntu here, so although Transmission 1.34 was the version I was running when I found this, there's a chance I may have been running an older version when that torrent was first added. If that part isn't easily reproducable with 1.42 I wouldn't worry about it.

comment:6 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from assigned to closed

Closing as invalid for now.

Anyone is free to reopen this ticket if they find a way to trigger this behavior in newer versions of Transmission..

Note: See TracTickets for help on using tickets.