Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1748 closed Bug (fixed)

crash in event_queue_insert in thread1

Reported by: Biiaru Owned by: charles
Priority: Normal Milestone:
Component: libtransmission Version: 1.42+
Severity: Normal Keywords:
Cc:

Description

Crash log attached.

Attachments (4)

Transmission_2009-01-24-101904_Winter.crash (20.1 KB) - added by Biiaru 12 years ago.
Transmission_2009-01-24-184840_Winter.crash (31.3 KB) - added by Biiaru 12 years ago.
Similar Thread 1 appearance. Segfault on start, r7795.
Transmission_2009-01-24-225616_Winter.crash (61.2 KB) - added by Biiaru 12 years ago.
Disregard last upload. Description applies to this crash report.
Transmission_2009-01-25-133934_Winter.crash (21.0 KB) - added by Biiaru 12 years ago.
crash on start r7797, looks similar but not exactly the same

Download all attachments as: .zip

Change History (23)

comment:1 Changed 12 years ago by smmalis

Looking at the crash report, it seems to me that the crash was caused by libevent.

Changed 12 years ago by Biiaru

Similar Thread 1 appearance. Segfault on start, r7795.

Changed 12 years ago by Biiaru

Disregard last upload. Description applies to this crash report.

comment:2 Changed 12 years ago by charles

  • Summary changed from r7790 Crash on start (no assert) to crash in event_queue_insert in thread1

comment:3 Changed 12 years ago by charles

This occurs in a couple of those attachments:

49 	Thread 1 Crashed:
50 	0   org.m0k.transmission      0x00092112 event_queue_insert + 96
51 	1   org.m0k.transmission      0x000905b5 kq_dispatch + 304
52 	2   org.m0k.transmission      0x0009352a event_base_loop + 795
53 	3   org.m0k.transmission      0x00093ae4 event_dispatch + 35
54 	4   org.m0k.transmission      0x0007494a libeventThreadFunc + 183
55 	5   libSystem.B.dylib         0x94b3c095 _pthread_start + 321
56 	6   libSystem.B.dylib         0x94b3bf52 thread_start + 34

comment:4 Changed 12 years ago by charles

http://forum.transmissionbt.com/viewtopic.php?f=4&t=6934&start=0 has a few more of these, with this one twice:

Thread 1 Crashed:
0   org.m0k.transmission   0x00092112 event_queue_insert + 96
1   org.m0k.transmission   0x000905b5 kq_dispatch + 304
2   org.m0k.transmission   0x0009352a event_base_loop + 795
3   org.m0k.transmission   0x00093ae4 event_dispatch + 35
4   org.m0k.transmission   0x0007494a libeventThreadFunc + 183
5   libSystem.B.dylib      0x900d8095 _pthread_start + 321
6   libSystem.B.dylib      0x900d7f52 thread_start + 34

And this one once:

Thread 1 Crashed:
0   org.m0k.transmission    0x0009215b event_queue_insert + 169
1   org.m0k.transmission    0x000905b5 kq_dispatch + 304
2   org.m0k.transmission    0x0009352a event_base_loop + 795
3   org.m0k.transmission    0x00093ae4 event_dispatch + 35
4   org.m0k.transmission    0x0007494a libeventThreadFunc + 183
5   libSystem.B.dylib       0x900d8095 _pthread_start + 321
6   libSystem.B.dylib       0x900d7f52 thread_start + 34

Changed 12 years ago by Biiaru

crash on start r7797, looks similar but not exactly the same

comment:5 Changed 12 years ago by charles

from persept, who said it did not happen at startup but rather while T was running in the background:

Thread 1 Crashed:
0   org.m0k.transmission   0x000a6e51 event_queue_insert + 120
1   org.m0k.transmission   0x000a6678 event_active + 110
2   org.m0k.transmission   0x000a31c1 kq_dispatch + 691
3   org.m0k.transmission   0x000a5ca5 event_base_loop + 389
4   org.m0k.transmission   0x000a5b1a event_loop + 44
5   org.m0k.transmission   0x000a5954 event_dispatch + 24
6   org.m0k.transmission   0x00084fdc libeventThreadFunc (trevent.c:253)
7   org.m0k.transmission   0x00074227 ThreadFunc + 34 (platform.c:112)
8   libSystem.B.dylib      0x93507095 _pthread_start + 321
9   libSystem.B.dylib      0x93506f52 thread_start + 34

comment:6 Changed 12 years ago by charles

From ryoujin:

0   org.m0k.transmission   0x00092112 event_queue_insert + 96
1   org.m0k.transmission   0x000905b5 kq_dispatch + 304
2   org.m0k.transmission   0x0009352a event_base_loop + 795
3   org.m0k.transmission   0x00093ae4 event_dispatch + 35
4   org.m0k.transmission   0x0007494a libeventThreadFunc + 183
5   libSystem.B.dylib      0x900d8095 _pthread_start + 321
6   libSystem.B.dylib      0x900d7f52 thread_start + 34

comment:7 Changed 12 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles
  • Version changed from 1.42 to 1.42+

comment:8 Changed 12 years ago by charles

I have no idea why this crash is happening, but from what Biiaru and others have said it sounds like it was added relatively recently... I haven't even seen it happen once, so maybe it has something to do with the way the Mac client interacts with libtransmission.

Regardless, I think the thing to do now is for you to start working backwards through the nightlies to figure out when this bug was introduced. You will probably want to coordinate your efforts...

comment:9 Changed 12 years ago by charles

Possible fix in trunk in r7824

comment:10 Changed 12 years ago by charles

xref: this is being experienced by KingJulian and lizardflix in the forums.

comment:11 Changed 12 years ago by charles

related: charles * r7828 libtransmission/web.c: (trunk libT) #1748: judging from Biiaru's testing yesterday after I left, the problem is somewhere in web.c. Let's start digging in there by adding in some cruel assertions...

comment:13 Changed 12 years ago by charles

A typical report:

2/5/09 3:18:36 PM [0x0-0x10010].org.m0k.transmission[99] [15:18:36.995] Transmission 1.42+ (7829) Assertion "mcode == CURLM_OK" failed at /var/tmp/pea/svn.transmissionbt.com/trunk/libtransmission/web.c:321.  (curl_multi_socket_action() failed: 5 (invalid socket argument))  Please report this bug at <http://trac.transmissionbt.com/newticket>; Thank you.
2/5/09 3:18:41 PM com.apple.launchd[62] ([0x0-0x10010].org.m0k.transmission[99]) Exited abnormally: Abort trap 

comment:14 Changed 12 years ago by charles

2/5/09 3:18:36 PM [0x0-0x10010].org.m0k.transmission[99] [15:18:36.995] Transmission 1.42+ (7829) Assertion "mcode == CURLM_OK" failed at /var/tmp/pea/svn.transmissionbt.com/trunk/libtransmission/web.c:321. (curl_multi_socket_action() failed: 5 (invalid socket argument)) Please report this bug at <http://trac.transmissionbt.com/newticket>; Thank you. 2/5/09 3:18:41 PM com.apple.launchd[62] ([0x0-0x10010].org.m0k.transmission[99]) Exited abnormally: Abort trap

comment:15 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.50
  • Status changed from new to assigned

comment:16 Changed 12 years ago by Biiaru

  • Resolution set to fixed
  • Status changed from assigned to closed

I believe this is fixed as of r7866. I'll reopen if I do experience it again.

comment:17 Changed 12 years ago by livings124

  • Milestone changed from 1.50 to None Set

comment:18 Changed 12 years ago by livings124

  • Milestone None Set deleted

comment:19 Changed 12 years ago by charles

xref: #1844

Note: See TracTickets for help on using tickets.