Opened 12 years ago

Closed 12 years ago

#1764 closed Bug (duplicate)

"Invalid socket argument" from libcurl

Reported by: fonam Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.42+
Severity: Normal Keywords: invalid socket argument, 1.50b3
Cc:

Description

Throughout the 1.50 Beta's this has been getting worse. See log. A lot of messages stating 'invalid socket argument'. They come back on a regular base.Using private/open trackers at the same time, no special settings (only upload limit). maxium global peers: 550. new transfers: 220. Using 1.50b3

Attachments (1)

28012009 (1.50b3).txt (172.5 KB) - added by fonam 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by fonam

comment:1 Changed 12 years ago by charles

  • Summary changed from Invalid socket argument to "Invalid socket argument" from libcurl

The web.c:303 line in question is the tr_err() at the end of this block:

    /* invoke libcurl's processing */
    do {
        rc = curl_multi_socket_action( g->multi, fd, 0, &g->still_running );
        dbgmsg( "event_cb(): fd %d, still_running is %d",
                fd, g->still_running );
    } while( rc == CURLM_CALL_MULTI_PERFORM );
    if( rc != CURLM_OK )
        tr_err( "%s", curl_multi_strerror( rc ) );

comment:2 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This has the same root cause as #1748

Note: See TracTickets for help on using tickets.