Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1765 closed Bug (fixed)

If a downloaded file disappears, stop the torrent instead of redownloading it

Reported by: viktor Owned by: charles
Priority: Normal Milestone: 1.74
Component: libtransmission Version: 1.42
Severity: Major Keywords: dataloss
Cc:

Description

1.50b3

My downloads are set to a partition I need to mount (Ubuntu Linux). This time I just realized the partition wasn't mounted as I launched Transmission, so I did has it was already connecting to the tracker (for the sole leeching file at least).

Problem is it started downloading the whole torrent back from 0%. I paused, exited then restarted and checked files. It checked the files slowly and eventually got only about 25% completed from almost 60% when I last stopped.

Transfer stats for this torrent: ~360 MB done (and verified) vs. ~840 MB received (and 0 failed)

Change History (8)

comment:1 Changed 12 years ago by charles

What happened was that when you started downloading the whole torrent back from 0%, you overwrote the original session's state information about which incomplete pieces it had downloaded and which it hadn't. Because of that, when "verify local data" was run, it could only confirm the complete pieces that had been downloaded.

Once that state information is lost, there's nothing that can be done about this. IMO the solution is to not allow a torrent to start when its directory has disappeared.

comment:2 Changed 12 years ago by charles

  • Summary changed from Failure to check files on loading causes loss of downloaded parts to If a downloaded file disappears, stop the torrent instead of redownloading it

comment:3 Changed 12 years ago by charles

  • Keywords dataloss added; beta3 intrepid checking removed
  • Owner set to charles
  • Status changed from new to assigned

comment:4 Changed 12 years ago by charles

#1430 has been marked as a duplicate of this ticket.

comment:5 Changed 12 years ago by charles

At http://brainstorm.ubuntu.com/idea/19800/ this has 49 votes from Ubuntu users

comment:6 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.74
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version changed from 1.42+ to 1.42

Fixed in trunk by r8915 for 1.74

comment:7 Changed 12 years ago by charles

Ticket #2333 has been closed as a duplicate of this ticket.

comment:8 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
Note: See TracTickets for help on using tickets.