Opened 13 years ago

Closed 12 years ago

#1769 closed Bug (invalid)

Tracker pane shows "In progress" too often for ipv6 connections

Reported by: gnu Owned by: jhujhiti
Priority: Normal Milestone: Sometime
Component: libtransmission Version: 1.50
Severity: Normal Keywords:
Cc:

Description

I'm running 1.50b3 (7776) on Ubuntu Hardy, using the GTK+ GUI, on a T1 line, with several dozen ipv4 torrents seeding, and one IPv6 torrent downloading or seeding. While downloading, it seems to have stopped reporting to the tracker.

At 20:12, the tracker pane shows "Last scrape at 18:09:41" and "Last announce at 17:26:31", and also reports "Next scrape in: In progress" and "Next announce in: In progress" and "Manual announce allowed in: In progress". They have been in progress for several hours. It seems to be getting hung up and unable to make those scrapes or announcements.

The torrent I'm downloading is: http://ipv6.torrent.ubuntu.com:6969/torrents/ubuntu-8.10-alternate-amd64.ipv6.iso.torrent?4AB6A5C55E5FCFB6F994A9C2B400710FB80D0C90

The tracker is here: http://ipv6.torrent.ubuntu.com:6969/index.tmpl The line for this torrent currently shows 3 seeds, 0 peers, completed: 16. When I first started the torrent, it showed up as 1 peer at 0% complete. But after a few minutes, that disappeared.

Both this torrent's tracker, and all its peers, are on IPv6 networks.

Change History (13)

comment:1 Changed 13 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles

comment:2 Changed 13 years ago by jhujhiti

  • Milestone changed from None Set to 1.50
  • Owner changed from charles to jhujhiti

comment:3 Changed 13 years ago by charles

This isn't a Real Fix, but is one option if we decide to punt IPv6 support to 1.51:

curl_easy_setopt( easy, CURLOPT_IPRESOLVE, CURL_IPRESOLVE_V4 );

comment:4 Changed 13 years ago by charles

whoops, that last comment was meant for #1731

comment:5 Changed 13 years ago by jhujhiti

gnu, given the bug I strongly suspect is Azeurus' fault in your other ticket, could you try to reproduce this behavior on a different tracker? SixXS has an IPv6 tracker at https://www.sixxs.net/tools/tracker/

comment:6 Changed 13 years ago by livings124

gnu: ping

comment:7 Changed 13 years ago by gnu

That tracker www.sixxs.net (www.m.sixxs.net) is advertised at both IPv6 address 2001:838:1:1:210:dcff:fe20:7c7c and at two IPv4 addresses, 213.204.193.2 and 193.109.122.244. It doesn't answer for me at the IPv6 address.

The tracker came up after a few minutes, at its IPv6 address (and at both IPv4 addresses). I selected the "NSA Forms 2" torrent from this page: https://www.sixxs.net/tools/tracker/feed/rss/ ; it's called 3870566d59b4f9d88086e2e6db3f74a8942a6ff7.torrent . When I added it to the Transmission nightly (svn 7861, already running), it goes in, but won't start, saying the tracker is giving it "Bad Request (400)". I'll try another one.

I tried "Warriors of the Net", which is listed as available. It produced the same result.

When I go to "http://tracker.sixxs.net" which is the address listed in the Warriors torrent, it redirects me to the above page. When I go to "http://tracker.sixxs.net/announce" it complains validly that I'm not following BT protocol. The :6969 address doesn't answer. I don't see any other way to investigate what's wrong. I give up on this tracker for now.

I tried going to the Hungarian IPv6 torrent tracker referred to by sixxs's webpage. It only offers one file: http://ipv6.niif.hu/index.php?mn=3&sm=6&lg=en I downloaded that torrent (FreeBSD 7.0) but was unable to add it to Transmission because Transmission reported "Couldn't add corrupt torrent". Aha, the "torrent" is an HTML "403 Forbidden" page; these people never tested their webserver.

Have any other suggestions?

(PS: Both websites' info about Transmission as a client for IPv6 is way out of date. I suggest sending them an update saying that 1.50 betas work with ipv6.)

comment:8 Changed 13 years ago by jhujhiti

  • Milestone changed from 1.50 to 1.51

comment:9 Changed 13 years ago by charles

  • Milestone changed from 1.51 to 1.60

comment:10 Changed 13 years ago by charles

  • Version changed from 1.42+ to 1.50

comment:11 Changed 13 years ago by jhujhiti

  • Milestone changed from 1.60 to Sometime

comment:12 Changed 12 years ago by charles

None of the trackers listed in the above examples exist anymore. I don't know where to begin to test this in a newer version of Transmission.

comment:13 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

I'm closing this ticket because it's languished for over a year with no apparent interest from users. It seems that users either aren't having this problem, or that ipv4 hasn't yet made a dent in the BitTorrent? tracker world.

If there is still a problem I would be happy to address it. If someone encounters this issue again please reopen this ticket and answer these two questions:

  • Is this reproducible?
  • If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Note: See TracTickets for help on using tickets.