Opened 13 years ago

Closed 12 years ago

#1770 closed Bug (duplicate)

IPv6 torrent doesn't start at first scrape -- only later.

Reported by: gnu Owned by: jhujhiti
Priority: Normal Milestone: Sometime
Component: libtransmission Version: 1.50
Severity: Normal Keywords:
Cc: eric.petit@…

Description

I'm running 1.50b3 (7776) on Ubuntu Hardy, using the GTK+ GUI, on a T1 line, with several dozen ipv4 torrents seeding, and one or two IPv6 torrents downloading or seeding.

I downloaded http://ipv6.torrent.ubuntu.com:6969/torrents/ubuntu-8.10-desktop-amd64.ipv6.iso.torrent?77951450427226F8F3528DBDB7E519DA13F810CA and started it with the "Add" menu item, with "Start" checked by default.

The tracker reports it with 7 seeds, 1 peer, 43 successful downloads, average peer at 0%. No peers appear in my local client after the first scrape; they only appear after the first announce (and they appear within seconds after that announce). The first announce is delayed by 1 minute 30 seconds from the scrape (and the start of the torrent).

After I Pause it and then Start it, no peers appear for almost 2 minutes. A scrape occurred at 20:32:52, the Last announce was at 20:32:51, response was OK(200). Next announce in 2 minutes 10 seconds, manual announce allowed slightly earlier. As those 2 minutes go by, no peers appeared until close to the end of that period.

Shouldn't transmission be immediately trying to contact some of the peers that the tracker has told it about, rather than waiting for a few minutes?

Change History (9)

comment:1 Changed 13 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles

comment:2 Changed 13 years ago by jhujhiti

  • Milestone changed from None Set to 1.50
  • Owner changed from charles to jhujhiti

This is a bug in the Azureus tracker, I think. I have been told by a developer that it's been fixed, so I think bit.nl just needs to upgrade. I will not close this ticket until I regain IPv6 connectivity and confirm that it's actually not my problem ;)

comment:3 Changed 13 years ago by jhujhiti

  • Milestone changed from 1.50 to 1.51

comment:4 Changed 13 years ago by charles

  • Milestone changed from 1.51 to 1.60

comment:5 Changed 13 years ago by charles

  • Version changed from 1.42+ to 1.50

comment:6 Changed 13 years ago by titer

  • Cc eric.petit@… added

I am having trouble with ipv6.torrent.ubuntu.com torrents as well, with T always indicating "No Response (0)" for both announce and scrape. The same torrent starts downloading right away in Vuze on the same computer. Something odd is that if I run tcpdump while T is supposedly querying the tracker, I see no query at all going out. I'll try to look into that.

comment:7 Changed 13 years ago by titer

My problem was actually with CURLOPT_IPRESOLVE being set to CURL_IPRESOLVE_V4 (ref #1731), this tracker having an IPv6 address only. The torrent does download once I change that, but it also took a long time (like a couple minutes) to connect to peers.

comment:8 Changed 13 years ago by jhujhiti

  • Milestone changed from 1.60 to Sometime

comment:9 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This seems to be a duplicate of ticket #1631.

Note: See TracTickets for help on using tickets.