Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1782 closed Bug (invalid)

1.50b4 assertion failure

Reported by: G33k Owned by:
Priority: Normal Milestone:
Component: Transmission Version: 1.42+
Severity: Normal Keywords:
Cc:

Description (last modified by charles)

Problem Details:
Process:         Transmission [2492]
Path:            /Applications/Transmission.app/Contents/MacOS/Transmission
Identifier:      org.m0k.transmission
Version:         1.50b4 (7815)
Code Type:       PPC (Native)
Parent Process:  launchd [1771]

Date/Time:       2009-02-01 23:06:05.887 +0100
OS Version:      Mac OS X 10.5.6 (9G55)
Report Version:  6

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread:  1

Thread 0:
0   libSystem.B.dylib             	0x91105158 mach_msg_trap + 8
1   libSystem.B.dylib             	0x9110c07c mach_msg + 56
2   com.apple.CoreGraphics        	0x91f8b504 _CGSSetNotifications + 136
3   com.apple.CoreGraphics        	0x9201f924 CPSClearNotifications + 80
4   com.apple.AppKit              	0x9636d670 -[NSApplication terminate:] + 584
5   com.apple.AppKit              	0x962a7834 -[NSApplication sendAction:to:from:] + 104
6   com.apple.AppKit              	0x96343160 -[NSMenu performActionForItemAtIndex:] + 408
7   com.apple.AppKit              	0x96342e90 -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 228
8   com.apple.AppKit              	0x96342b58 -[NSMenu performKeyEquivalent:] + 744
9   com.apple.AppKit              	0x9634163c -[NSApplication _handleKeyEquivalent:] + 456
10  com.apple.AppKit              	0x96277d00 -[NSApplication sendEvent:] + 3676
11  com.apple.AppKit              	0x961e4dc0 -[NSApplication run] + 776
12  com.apple.AppKit              	0x961b579c NSApplicationMain + 440
13  org.m0k.transmission          	0x00002890 0x1000 + 6288
14  org.m0k.transmission          	0x000027ec 0x1000 + 6124
15  org.m0k.transmission          	0x000024fc 0x1000 + 5372
16  ???                           	0x00000ffc 0 + 4092

Thread 1 Crashed:
0   libSystem.B.dylib             	0x9120ec7c nanosleep$NOCANCEL$UNIX2003 + 0
1   libSystem.B.dylib             	0x9114f9c4 _fwalk + 76
2   libSystem.B.dylib             	0x91221bb4 abort + 92
3   org.m0k.transmission          	0x0008fb5c 0x1000 + 584540
4   org.m0k.transmission          	0x0006726c 0x1000 + 418412
5   org.m0k.transmission          	0x0007c428 0x1000 + 504872
6   org.m0k.transmission          	0x0007cdb8 0x1000 + 507320
7   org.m0k.transmission          	0x00085b88 0x1000 + 543624
8   org.m0k.transmission          	0x0006753c 0x1000 + 419132
9   libSystem.B.dylib             	0x91147024 _pthread_start + 316

Change History (7)

comment:1 Changed 13 years ago by charles

  • Description modified (diff)
  • Milestone 1.50 deleted
  • Summary changed from Bug to 1.50b4 assertion failure
  • Version set to 1.42+

Thanks for taking the time to report this.

It looks like the people who built the 1.50b4 mac binary stripped out all the debugging information, so unfortunately this isn't as useful as I would hope. I'll have to yell at them for that. >:)

There are two things we can do here:

(1) In Console.app, select LOG DATABASE QUERIES > Console Messages, and search for Transmission. If you find a message that mentions an assertion failure, attach it to this ticket.

(2) Download a nightly build from http://www.transmissionbt.com/download.php#nightlies. I'm told that the nightlies are built with debugging information, and the backend in the nightlies currently identical to that in 1.50b4... this way if the crash happens again in the nightly, we'll have more useful information to work with.

comment:2 Changed 13 years ago by livings124

Beta 5 should have the debugging information. Can you try to reproduce this using the newer version?

comment:3 Changed 13 years ago by charles

G33k: ping

comment:4 Changed 13 years ago by G33k

To be honest, I have no idea how I crashed it, and charles, what do you mean by "ping"?

Is it caused by a latency that's too high?

comment:5 Changed 13 years ago by charles

G33k: "ping" is polite shorthand for "we need to talk". In this particular case the ping was to call attention to livings124's comment, asking if the problem persists in 1.50 beta 5...

comment:6 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

G33k: please reopen this ticket when you have more information; specifically, the Console.app > LOG DATABASE QUERIES > Console Messages > Transmission assertion failure message(s).

comment:7 Changed 13 years ago by G33k

It haz nozing :'(

Note: See TracTickets for help on using tickets.