Opened 13 years ago

Closed 13 years ago

#1785 closed Bug (fixed)

General vs. scheduled limits interaction

Reported by: naddy Owned by: charles
Priority: Normal Milestone: 1.60
Component: GTK+ Client Version: 1.42
Severity: Normal Keywords:
Cc:

Description

1.50b4 (7815)

The settings in the Preferences->Bandwidth tab of the GTK client interact in unexpected ways.

At the time when the scheduled limits are active

(1) if I change the general limits, the settings are immediately applied and override the scheduled limits. If I then change the scheduled limits, they take hold again; but

(2) if I change the scheduled limits, [Close] the preferences window, open the preferences again, the general limits have taken on the values of the scheduled limits.

In practical terms, this means that during the time period where the scheduled limits are active I cannot set the general limits to values different from the scheduled limits.

Change History (7)

comment:1 Changed 13 years ago by charles

  • Milestone changed from 1.50 to None Set

Naddy: I agree this needs to be fixed, but don't set milestones unless you've submitted a patch :)

comment:2 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.60
  • Status changed from new to assigned
  • Version changed from 1.42+ to 1.42

Reading through this, I see what's going on and it's not going to be easy to fix in time for 1.50. What's really needed is for off-hour speedlimits to be implemented into libtransmission.

comment:3 in reply to: ↑ description Changed 13 years ago by erudite

Yes this is quite annoying.

Thanks for recognizing it.

comment:4 Changed 13 years ago by sprewell

I just came across this bug myself, please fix.

comment:5 Changed 13 years ago by livings124

Obviously this is known - there's already a ticket. Either contribute a patch or wait patiently.

comment:6 Changed 13 years ago by livings124

#1947 appears to be a duplicate of this.

comment:7 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

I think this is fixed now in r8088 as a side-effect of #1950.

Note: See TracTickets for help on using tickets.