Opened 13 years ago

Closed 13 years ago

#1822 closed Bug (wontfix)

Crash on start (most likely related to curl)

Reported by: Biiaru Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.50
Severity: Normal Keywords:
Cc:

Description

No assert:

2/14/09 3:14:24 PM ReportCrash?[2351] Formulating crash report for process Transmission[2346] 2/14/09 3:14:27 PM ReportCrash?[2351] Saved crashreport to /Users/nadare/Library/Logs/CrashReporter/Transmission_2009-02-14-151418_Winter.crash using uid: 501 gid: 20, euid: 501 egid: 20 2/14/09 3:14:25 PM com.apple.launchd[147] ([0x0-0xad0ad].org.m0k.transmission[2346]) Exited abnormally: Bus error

1.50.

Charles says to bundle in a new version of libcurl.

Attachments (1)

Transmission_2009-02-14-151418_Winter.crash (52.3 KB) - added by Biiaru 13 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 13 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

comment:2 Changed 13 years ago by charles

  • Component changed from libtransmission to Mac Client
  • Owner changed from charles to livings124

livings124: this is not a libtransmission issue. the error is caused by the mac client using an older, buggier version of libcurl. don't try to bounce this one off to me ;)

comment:3 Changed 13 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

I haven't seen others reporting this, and this does not seem repeatable. Since curl is included with the OS, which version is used is out of my hands. Since this isn't critical it doesn't currently justify bundling a newer curl.

Note: See TracTickets for help on using tickets.