Opened 13 years ago

Closed 12 years ago

#1836 closed Bug (duplicate)

Incorrect webseed status after torrent is completed, using transmission-remote -t X -i

Reported by: krx Owned by: charles
Priority: Lowest Milestone: Sometime
Component: libtransmission Version: 1.50
Severity: Trivial Keywords: patch-needed
Cc:

Description

When torrent is completed and enters seed mode, webseed status is incorrect, when torrent full info is viewed with transmission-remote -t X -i:

TRANSFER
'''  State: Seeding'''
  Location: /mmc/transmission/downloads
  Percent Done: 100%
  ETA: Unknown
  Download Speed: 0.0 KB/s
  Upload Speed: 10.5 KB/s
  Have: 1.1 GB (1.1 GB verified)
  Total size: 1.1 GB (1.1 GB wanted)
  Downloaded: 1.1 GB
  Uploaded: 314.1 MB
  Ratio: 0.28
  Corrupt DL: None
  Peers: connected to 5, uploading to 5, downloading from 0
'''  Web Seeds: downloading from 1 of 1 web seeds'''

Change History (12)

comment:1 Changed 13 years ago by livings124

  • Component changed from Transmission to Daemon
  • Owner set to charles

comment:2 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.51
  • Status changed from new to assigned

comment:3 Changed 13 years ago by charles

  • Summary changed from Incorrect webseed status after torrent is completed, when usig transmission-remote -t X -i to Incorrect webseed status after torrent is completed, using transmission-remote -t X -i

comment:4 Changed 13 years ago by charles

  • Milestone changed from 1.51 to 1.60

comment:5 Changed 13 years ago by charles

  • Component changed from Daemon to libtransmission

(breadcrumbs)

The code in transmission-remote looks correct, so I think this is a bug with the data coming back from libtransmission.

tr_stat.webseedsSendingToUs comes from tr_stat(), which gets it from tr_peerMgrTorrentStats(), which calculates the number by counting the number of webseeds that return true for tr_webseedIsActive(). So it looks like the bug is somewhere in webseed.c and how it decides if a webseed is active or not.

comment:6 Changed 12 years ago by charles

  • Milestone changed from 1.60 to 1.70

I'm not seeing the bug, and IMO webseeds aren't a high enough priority to hold up 1.60.

comment:7 Changed 12 years ago by charles

  • Milestone changed from 1.70 to Sometime

comment:8 Changed 12 years ago by charles

  • Resolution set to wontfix
  • Status changed from assigned to closed

There is only one developer currently working on libtransmission, and webseeds are a low priority because webseed .torrents are exceedingly rare. Unless they catch on more in the BitTorrent? world, this ticket is unlikely to be implemented.

This ticket would be an improvement to Transmission, at least to the extent that webseeds are used, so patches are welcomed. If someone out there feels strongly about webseeds, please attach a patch to this ticket and reopen the ticket. Thanks!

comment:9 Changed 12 years ago by livings124

Reopening because this is a valid issue that should be fixed sometime or other.

comment:10 Changed 12 years ago by livings124

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:11 Changed 12 years ago by charles

  • Keywords patch-needed added; web seed status incorrect command line info removed

comment:12 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed

Now it kind of makes sense. I think this is caused by the same bug that was fixed in #2204.

Note: See TracTickets for help on using tickets.