Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1841 closed Bug (fixed)

Transmission doesn't stick to maximum peer limits.

Reported by: Rolcol Owned by: charles
Priority: Normal Milestone: 1.73
Component: libtransmission Version: 1.72
Severity: Normal Keywords:
Cc: g.teunis@…, rfugger@…, mz.goleb@…

Description

Transmission does not stick to the maximum setting for peers per torrent. For example, I set my limit to 100 peers and I constantly see transmission connected to about 130. It eventually drops down to my limit but I have seen it jump up again.

Change History (14)

comment:1 Changed 13 years ago by livings124

#1861 is a duplicate of this.

comment:2 Changed 13 years ago by Rolcol

  • Version changed from 1.50 to 1.51

Do you know the part of the code that causes this?

comment:3 Changed 13 years ago by Robby

Yeah, I have 60 set and T likes to connect to 70+.

comment:4 Changed 12 years ago by charles

#2082 has been marked as a duplicate of this ticket.

comment:5 Changed 12 years ago by Ger Teunis

  • Cc g.teunis@… added

comment:6 Changed 12 years ago by Ger Teunis

Can I help in anyway in solving this bug? If this bug is solved it might just make transmission more stable on the NMT platform.

comment:7 Changed 12 years ago by rfugger

This may be related: I've noticed that Transmission (using 1.71 on Ubuntu) seems to completely ignore when I set maximum peers on an individual torrent's properties when it is lower than the global max-peers-per-torrent setting.

comment:8 Changed 12 years ago by rfugger

  • Cc rfugger@… added

comment:9 Changed 12 years ago by m_gol

  • Cc mz.goleb@… added

I can confirm it; Transmission 1.71, Ubuntu 8.04. It is IMHO critical, as I'm simply unable to use Transmission AT ALL, because then I cannot browse the internet (even simple pages don't load).

comment:10 Changed 12 years ago by m_gol

  • Version changed from 1.51 to 1.72

Pardon, it's even 1.72. I change the version number as it suggests that only older builds are affected.

comment:11 Changed 12 years ago by m_gol

I can also say, that the description is not valid for me, it's even worse - not only the peers connected number is too large but it also doesn't lower to the limit at all, at all.

comment:12 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.73
  • Resolution set to fixed
  • Status changed from new to closed

fixed in trunk on r8781 for 1.73

comment:13 Changed 12 years ago by charles

r8782: fix r8781 oops

comment:14 Changed 12 years ago by charles

  • Priority changed from High to Normal
  • Severity changed from Major to Normal
Note: See TracTickets for help on using tickets.