Opened 12 years ago

Closed 12 years ago

#1848 closed Bug (worksforme)

Sometimes when a transfer finishes downloading, the ratio limit is not checked

Reported by: Wizardling Owned by:
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.51+
Severity: Normal Keywords:
Cc:

Description

I return to my mid-2007 24" 2.8GHz iMac running 10.5.6 and the latest nightly build of Transmission to find some torrents still seeding on 'forever' after they've sucessfully downloaded and reached their seeding limit.

I seem to be able to upload a lot faster for some torrents these days, than I can download. Though I'm not around when they finish downloading, I suspect the commonality is they reached their seeding limit before downloading 100%. I'm not certain, but I think that's what is shared by these torrents that are not being paused.

Change History (37)

comment:1 Changed 12 years ago by livings124

  • Version changed from 1.50 to 1.50+

comment:2 Changed 12 years ago by livings124

  • Summary changed from Some torrents are not paused after reaching their limits. to Some torrents are not paused after reaching ratio limit

comment:3 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

The ratio code has been updated quite a bit, and I can't replicate this. Please reopen if this is still repeatable.

comment:4 Changed 12 years ago by Wizardling

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Still happening for me in a build a couple days old, just trying build r7992 to see if that fixes it...

comment:5 Changed 12 years ago by livings124

No need to reopen until you've actually tested it...

comment:6 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

Closing until this is verified to not work in a current build.

comment:7 Changed 12 years ago by Wizardling

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Still broken in build 8001. Are you sure you tried torrents that had already reached their upload limit _before_ they finished downloading? I believe this is the key :-)

comment:8 Changed 12 years ago by livings124

I just tested it this way:

Set a seed ratio lower than equal ratio. Let the download finish to conclusion. The transfer switches to pause, and ratio is set to "seed forever".

Are you doing something different? Do you have a queue set, and if so does disabling it fix this?

comment:9 Changed 12 years ago by Wizardling

I just tested again - set a torrent to download and have an upload ratio of 0.25 (to make sure it reached the upload limit before finishing downloading). It finished downloading and switched to unlimited uploading. I don't use sets at all. Is there any way I can provide more info? A debug version of Transmission? Let me know how I can help pin down this bug for you :-)

comment:10 Changed 12 years ago by livings124

It switches to unlimited, but did it stop? Do you have a queue enabled?

comment:11 Changed 12 years ago by Wizardling

No, it switches to unlimited and stays uploading (which costs me a lot in NZ where you pay per MB still). Yes, I do have a queue set up. One of each type (downloading/uploading) at once, though Transmission frequently starts multiple torrents in defiance of these settings.

comment:12 Changed 12 years ago by livings124

Can you disable the queue and see if this still happens?

comment:13 Changed 12 years ago by livings124

  • Summary changed from Some torrents are not paused after reaching ratio limit to Some torrents are not paused after reaching ratio limit (with queue enabled on Mac)

comment:14 Changed 12 years ago by livings124

Please try r8014.

comment:15 Changed 12 years ago by livings124

  • Summary changed from Some torrents are not paused after reaching ratio limit (with queue enabled on Mac) to Sometimes when a transfer finishes downloading, the ratio limit is not checked

comment:16 Changed 12 years ago by Wizardling

Well with 8011 I've had one torrent finish downloading while already having reached it's upload limit and with queues turned off. It did not stay uploading - it stopped :-)

I've a few other similar torrents going that will finish today. Or I can switch to 8014 right now, but then it will be hard to say for sure that it was turning off queuing that made the difference (assuming 8014 makes a change).

If you do want me to immediately switch do you want me to keep queuing off or turn it back on (my usual preference)?

comment:17 Changed 12 years ago by charles

I've a few other similar torrents going that will finish today. Or I can switch to 8014 right now, but then it will be hard to say for sure that it was turning off queuing that made the difference (assuming 8014 makes a change).

This makes sense to me. Go ahead and finish testing with 8011 so that we've got a decent baseline, then upgrade to 8014 and try some more downloads. :)

comment:18 Changed 12 years ago by Wizardling

Yup, it would seem that turning of queuing works. I've had five torrents finish and none stayed running as usual. I'll try the newer nightly now with queuing back on.

comment:19 Changed 12 years ago by Wizardling

Seems to be fixed as of the last couple nightlies, but there is the crash occurring as many torrents finish, so I'm hesitant to close it till I can get half a dozen torrents finishing without crashes.

comment:20 Changed 12 years ago by livings124

The crash is #1894.

comment:21 Changed 12 years ago by Wizardling

Still present in build 8096.

comment:22 Changed 12 years ago by livings124

What is still present? Not stopping or crashing?

comment:23 Changed 12 years ago by Wizardling

Not stopping once the upload limit is reached.

comment:24 Changed 12 years ago by Wizardling

Well, and the crashes too. Sorry for not being explicit. Just woke up.

comment:25 Changed 12 years ago by charles

  • Component changed from Transmission to Mac Client

Since it works without queueing, and queueing is part of the mac client, I'm reassigning this ticket's component...

comment:26 Changed 12 years ago by Wizardling

Still happening as of build 8161.

comment:27 Changed 12 years ago by livings124

Wizardling: can you try a current nightly?

comment:28 Changed 12 years ago by Wizardling

Always am :-) I'll advise when I see - say half a dozen (to be sure) torrents finish without a hitch.

comment:29 Changed 12 years ago by Wizardling

Confirmed still present in build #8214. The good news is Transmission didn't crash this time a torrent finished downloading.

comment:30 Changed 12 years ago by livings124

Can you please post a video of this. You are the only user to ever report this and I'd like to see this in action.

comment:31 Changed 12 years ago by Wizardling

Is there no debug version that can log it happening instead? If not I suppose I can install some screen video capture software.

BTW - if you set Mac Transmission's seeding ratio to 0.25 (to ensure upload limit is reached before download is complete) you do not experience the same problem (that uploading is switched to unlimited after downloading is finished, and the transfer is not paused)? Assuming it's not something peculiar to my setup, it ought to be fairly easy to replicate.

I am using OSX 10.5.6 running on a mid-2007 24" iMac. Though I'd be surprised if the exact Mac model is needed to replicate this :-D

FYI: I don't always have the seeding ratio set so low - it's not very polite after all. I DO like to give back. However in NZ I pay per MB transferred and due a move on my part it has now got a lot more expensive for me. Thus I like to manually control exactly what torrents I'm seeding (by restarting only those I feel are worthy of the expense), and see little point in seeding torrents that already have hundreds or thousands of existing seeders. Instead I prefer those with very few seeders which is I feel more important to contribute to, given I can only afford to upload so much.

Anyway - I just wanted to explain why I have the ratio set so low. I know the reasons why are not important in terms of troubleshooting, but I don't like to be thought of as a jerk :-)

comment:32 Changed 12 years ago by livings124

There is no debug version to get the info we need. Right now I just want to see what you're talking about in action.

comment:33 Changed 12 years ago by livings124

Wizardling: ping

comment:34 Changed 12 years ago by Wizardling

Any suggestions for free video screen capture software for OSX? I used Snapz Pro back in MacOS classic days, but am not keen on paying for an upgrade to software I no longer need.

comment:35 Changed 12 years ago by livings124

No clue. Check google.

comment:36 Changed 12 years ago by livings124

Wizardling: ping

comment:37 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

Until I get more information I can't do anything with this.

Note: See TracTickets for help on using tickets.