Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1864 closed Bug (fixed)

Tracker not found (404) when a check of local file is done.

Reported by: howl Owned by:
Priority: Normal Milestone: 1.72
Component: GTK+ Client Version: 1.50
Severity: Normal Keywords: needinfo
Cc:

Description

When adding a torrent and transmission is set to autostart it if there is no local data all works as is expected, transmission connects to the tracker and get peers to download/upload from. But when this is done with a torrent that there is file locally and it's added transmission is checking the file as is expected but when it finishes and autostart the torrent in the info of the torrents it stays in a 404 tacker not found and it the next updates the same.

Pausing and restarting the torrent makes transmission to be able to connect the tracker, receive peers and works perfect.

I think this should be set for the 1.51 milestone.

Thanks.

Attachments (2)

8460-Main-Transmission.png (64.6 KB) - added by Rolcol 12 years ago.
Torrent 1 is a large torrent that was being verfied due to a crash before 2 and 3 were added. 2 and 3 were waiting to verify. I paused 1 to allow 2 and 3 to start but they did not contact the tracker. 2 did not start until it was paused and restarted. 3 has not been restarted and will not contact the tracker.
8460-Properties-of-3.png (46.4 KB) - added by Rolcol 12 years ago.
This is the properties window for torrent 3 of my last attachment.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 13 years ago by charles

I'm not able to reproduce this...

comment:2 Changed 13 years ago by howl

I have done this in ubuntu hardy and intrepid.

comment:3 Changed 13 years ago by howl

Also i have tried in two different computers and with 1.22 or 1.34 this doesn't happen so i think I could explain it wrong.

Initial state: Transmission set to autostart torrents when added, a file existing locally (partially or completed doesn't matter), it's respective torrent mustn't be in transmission.

Steps to reproduce: 1.- Add the torrent to transmission and point it where we have the file. 2.- Don't let transmission to complete the check of the file while we are in the torrents setting window, add it just after pointing the torrent to the folder the file is. 3.- Wait to the torrent to be fully checked. 4.- The bug appears.

In this state if we don't pause and restart the torrent it will never receive peers.

comment:4 Changed 13 years ago by KyleK

I regularly add torrents to Transmission where the data is already complete (for seeding purposes) and I have never encountered this. Transmission starts verificating the file(s), and after it's done it connects to peers to upload data.

comment:5 Changed 13 years ago by howl

I'm testing with big files, now I have just tested with a 5,4GiB file. When the check finish the torrent is started but going to the tracker info in the torrent settings says last announce never and next announce never.

comment:6 Changed 13 years ago by livings124

  • Summary changed from Tacker not found (404) when a check of local file is done. to Tracker not found (404) when a check of local file is done.

comment:7 Changed 13 years ago by charles

I've just tried this with three separate torrents and can't reproduce this...

comment:8 Changed 13 years ago by Rolcol

I've had this happen to me but I can't reproduce it on demand. I'll keep trying.

comment:9 Changed 13 years ago by Rolcol

<Rolcol> charles_: I just had it happen to me <Rolcol> The field was left blank rather than saying 404 <Rolcol> Scrape works <Rolcol> charles_: It also says that a manual announce is allowed but It won't really allow it

I downloaded the .torrent of a big (800+MB) file I already had completed. Transmission immediately began to verify it and it was able to Scrape but Announce didn't work. Again, it's "fixed" by pausing and restarting the torrent. I was able to reproduce it twice with the same torrent.

comment:10 Changed 13 years ago by howl

I don't know about the scrape info because the tracker where I test do not provide the scrape.

comment:11 follow-up: Changed 13 years ago by howl

I'm not having this problem with transmission-daemon 1.51. When I have time I will try with transmission-gtk 1.51 as I had the issue with the gtk 1.50 but don't know if the daemon 1.50 have the problem.

comment:12 in reply to: ↑ 11 Changed 13 years ago by Rolcol

Replying to howl:

I'm not having this problem with transmission-daemon 1.51. When I have time I will try with transmission-gtk 1.51 as I had the issue with the gtk 1.50 but don't know if the daemon 1.50 have the problem.

This is in the latest SVN trunk too. I started a torrent on Mac and moved the file onto my flash drive to finish it on my laptop but it didn't communicate with the tracker when the verification was finished. I had to pause and restart my torrent. Both the Mac client and the GTK client are at r8046.

comment:13 Changed 12 years ago by howl

  • Version changed from 1.50 to 1.52

This bug is already present in 1.52

comment:14 Changed 12 years ago by livings124

  • Version changed from 1.52 to 1.50

comment:15 Changed 12 years ago by howl

I wasn't asking, really this bug is still present, but as you wish ;)

comment:16 Changed 12 years ago by livings124

If the bug wasn't present the ticket would be closed. ;)

How do you expect us to know when the bug originated if every open ticket had its version updated for every release?

comment:17 Changed 12 years ago by howl

Good point, sorry :)

comment:18 Changed 12 years ago by charles

Could you please test r8389 or higher and see if it fixes this problem?

comment:19 Changed 12 years ago by charles

  • Keywords needinfo added

comment:20 Changed 12 years ago by howl

Hello.

I can't test it until one mouth I will could test arround the 15 of the next mouth.

comment:21 Changed 12 years ago by charles

Why are you unable to test this for an entire month?

comment:22 Changed 12 years ago by howl

I'm out of my home for one month and I could update transmission remotely but I don't have anything like remote desktop to manage the ui.

The laptop I'm using runs windows xp and the live cd of ubuntu for example runs very bad on it because it only have 256 MiB of ram. Probably I could try to run xubuntu but adding the repository to upgrade transmission, download the packages and installation could consume the free memory.

comment:23 Changed 12 years ago by Rolcol

I have not run into this bug for a while now. I think it's finally fixed. I'll post again if otherwise.

comment:24 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

Changed 12 years ago by Rolcol

Torrent 1 is a large torrent that was being verfied due to a crash before 2 and 3 were added. 2 and 3 were waiting to verify. I paused 1 to allow 2 and 3 to start but they did not contact the tracker. 2 did not start until it was paused and restarted. 3 has not been restarted and will not contact the tracker.

Changed 12 years ago by Rolcol

This is the properties window for torrent 3 of my last attachment.

comment:25 Changed 12 years ago by Rolcol

  • Resolution fixed deleted
  • Status changed from closed to reopened

Using r8460. Not fixed :(

comment:26 Changed 12 years ago by charles

  • Component changed from Transmission to GTK+ Client
  • Milestone changed from None Set to 1.72

Ah, I see what's going on.

If you let the torrent finish verifying before closing the Torrent Options dialog, all is well. But if you close the dialog before verification is done, then the announce timer is never set properly.

comment:27 Changed 12 years ago by howl

Could be, in my case I always closed the Torrent Option dialog and let transmission to check it from the main window.

Also this bug could be in mac client, as was reported by RolCol?.

comment:28 Changed 12 years ago by charles

RolCol?'s using the gtk+ client, not the mac client.

comment:29 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in trunk r8683 for 1.72

comment:30 Changed 12 years ago by charles

Ticket #1956 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.