Opened 13 years ago

Closed 13 years ago

#1876 closed Enhancement (duplicate)

quit gracefully on session logout

Reported by: kostmo Owned by:
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 1.51
Severity: Minor Keywords:
Cc:

Description

It would be nice if, when the computer shuts down, all of the torrents are paused first, with a flag that unpauses them on the next startup. That way when it starts back up again, it won't have to go through the file verification process, which can be quite lengthy sometimes.

Change History (4)

comment:1 Changed 13 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

This doesn't make any season. Obviously transfers are stopped on shutdown and resumed on launch.

comment:2 Changed 13 years ago by kostmo

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from option to pause all on shutdown to quit gracefully on session logout

Maybe pausing isn't necessary.

Is it possible, instead, to automatically quit cleanly when a user logs out of GNOME?

I would just like to be able to logout of GNOME without having to explicitly click on Quit in Transmission first. As is, when I log out without manually commanding Transmission to "Quit", upon the next startup it has to run "Verifying local data" on all of the torrents.

comment:3 Changed 13 years ago by livings124

  • Component changed from Transmission to GTK+ Client

comment:4 Changed 13 years ago by charles

  • Resolution set to duplicate
  • Status changed from reopened to closed

This is a duplicate of #1248.

I've marked its milestone for 1.60.

Note: See TracTickets for help on using tickets.