Opened 13 years ago

Closed 13 years ago

#1881 closed Bug (fixed)

Displayed ratio should be truncated, not rounded

Reported by: boater Owned by: livings124
Priority: Normal Milestone: 1.60
Component: Transmission Version: 1.51
Severity: Minor Keywords:
Cc:

Description

I have noticed a couple of times recently in the Transmission window that the download ratio can be 1.00 yet the download remains active and seeding.

It would appear to be probably just just a cosmetic issue, maybe caused by the rounding of the download/upload ratio being equal to 1.0, yet the actual bytes would not be equal.

Change History (19)

comment:1 Changed 13 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is most likely a dupe of #1848 (and possibly related to #1823)

comment:2 Changed 13 years ago by boater

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#1848 relates to a "forever" remaining time estimate. When seeding "remaining time unknown" can be displayed, the download is complete.

This problem does not occur for a long period of time, which leads me to believe it might be a rounding issue. The connection is slow, and the 1.00 ratio appears for minutes or only a few hours before it pauses.

comment:3 Changed 13 years ago by livings124

  • Resolution set to duplicate
  • Status changed from reopened to closed

Your description makes it sound exactly like #1823.

comment:4 Changed 13 years ago by boater

  • Resolution duplicate deleted
  • Status changed from closed to reopened

The ratio wasn't lowered and files were not deselected, these were possible reasons for the problem in #1823.

comment:5 Changed 13 years ago by livings124

Can you try build 7978 and see if it works?

comment:6 Changed 13 years ago by livings124

Also, just to double check, you have finished downloading (the bar is green)?

comment:7 Changed 13 years ago by livings124

Also, is the issue on the released 1.51 or a nightly build?

comment:8 Changed 13 years ago by livings124

  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing, as this can be one of several things listed above. Reopen with more info if it is still an issue.

comment:9 Changed 13 years ago by boater

The problem occurred using version 1.50. I haven't tried build 7978, the problem hasn't occurred using 1.51 yet. It's not something that you can reproduce, I'll note it next time it happens, if it does.

comment:10 Changed 13 years ago by boater

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I have just seen the problem again, using version 1.51 (build 7958). Again, it doesn't seem applicable to either tickets mentioned. It doesn't appear to be a rounding issue (unless it is to the MB).

The details of the download are currently this:

77.2 MB, uploaded 77.0 MB (Ratio: 1.00) — 12 min 12 sec remaining

Seeding to 1 of 1 peer — UL: 0.5 KB/s

The transfer is paused to possibly assist in finding the cause of the problem.

comment:11 Changed 13 years ago by livings124

boater - the torrent's stop ratio is set to what? According to your post, it will reach the stop ratio in 12 min 12 sec. And ratio seems right: 77.2/77.0 = 1.0.

comment:12 Changed 13 years ago by boater

The stop ratio is set to 1.00.

Your calculation is inverted - it should be 77.0/77.2 = 0.997.

It is misleading when the ratio appears as 1.00 when the torrent is still seeding. It is noticeable enough that I've seen it on three torrents in the past couple of weeks. For example if a torrent is stuck slowly seeding at 990MB of 1000MB, it could display a ratio of 1.00 for some time.

This could be a solution: floor(0.997 * 100) / 100 = 0.99

Rather than: round(0.997) = 1.00

comment:13 Changed 13 years ago by livings124

Yup, you're right about the ratio - I inverted that. I will look into rounding down.

comment:14 Changed 13 years ago by livings124

  • Component changed from Mac Client to Transmission
  • Milestone changed from None Set to 1.60
  • Summary changed from Ratio possibly inaccurate in download list to Displayed ratio should be truncated, not rounded

This happens in all clients, apparently.

comment:15 Changed 13 years ago by livings124

  • Severity changed from Normal to Minor

comment:16 Changed 13 years ago by charles

Fixed in gtk+ client in r8015

comment:17 Changed 13 years ago by charles

Fixed in daemon in r8016

comment:18 Changed 13 years ago by livings124

Fixed in mac client in r8029

comment:19 Changed 13 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.