Opened 13 years ago

Closed 13 years ago

#1883 closed Bug (duplicate)

Resource intensive when transfer is > 1.5 ~ 2 MB/s

Reported by: shiretu Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.51
Severity: Blocker Keywords:
Cc:

Description

Hi,

Thank you for the effort invested in this software. Excellent work. But I have to report a "bug". Starting with revision 1.50 the app is very resource intensive. In fact is unusable if the transfer is greater than 1.5~2 MB/s. The reads and writes to and from disk are intensive, the UI is dead. I only have 3 torrents in the queue 2 of them are for seeding (about 200KB/s upload) and one is downloading at about 2MB/s. This bug is present in both 1.50 and 1.51. Version 1.42.7494 (which I'm running right now) is working excellent. Feel free to contact me if you want to make some live tests on my computer via iChat remote desktop.

Thank you

Attachments (1)

Picture 7.jpg (233.9 KB) - added by shiretu 13 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 13 years ago by livings124

You say you've tried this in 1.51, but the version is set to 1.50+. Have you tested this with the released 1.51?

comment:2 Changed 13 years ago by shiretu

Yes, minutes ago. Is blocking everything. The only way to close it is to kill it in which case is taking ages and the read/write on disk is intensive. If you want, as I said, I'll be here around 00:00 (Bucharest time) for you to see it live. Maybe you can get more info.

Thank you

comment:3 Changed 13 years ago by livings124

Can you run a Shark profile and post it here? http://trac.transmissionbt.com/wiki/Shark

comment:4 Changed 13 years ago by shiretu

Yes, I'll do it. I'll send it later tonight.

comment:5 Changed 13 years ago by charles

  • Summary changed from Resource intensive to Resource intensive when transfer is > 1.5 ~ 2 MB/s
  • Version changed from 1.50+ to 1.51

Are you using a local drive, or a remote drive, or a networked drive? It sounds like the system is getting stuck waiting for IO to finish.

comment:6 Changed 13 years ago by shiretu

No, the HDD is built in. I have a macbook white with 2.16 GHz 2GB ram and 120 GB HDD and Leopard 10.5.6 up to date. As I said, 1.42 is working EXCELENT.

Changed 13 years ago by shiretu

comment:7 Changed 13 years ago by shiretu

Back again.I just realized that I didn't work with Shark utility (or something similar) until now. Could you be more specific about what you want from it? Anyway I've prepared few screen-shoots. In the mean time I'll grab a copy of the sources and try to compile it with -O0 -g and after that try to attach to it with gdb in the moment of freezing. I'll post back a full stack trace. Hopefully this will help you.

Tx

comment:8 Changed 13 years ago by shiretu

Mea culpa! I just read the wiki about the Shark utility. After the post...

comment:9 Changed 13 years ago by charles

Looks like it's freezing while writing data to disk

comment:10 Changed 13 years ago by shiretu

I see that. What i don't understand is where is it gets it's data since the download is ~6MB/s and the data written on disk is at 24MB/s... Maybe is flushing some data but I doubt it because it lasts too long. How many bytes could it have stored in memory to keep the IO for so long at such a rate!? And one more thing... It's starting to act like this after a few seconds after starting the app. You can see from the little graph from Monitor that it's working great for the first ~30 seconds or so. I'll keep you informed after I get that stack trace...

comment:11 Changed 13 years ago by charles

This ticket is starting to look a lot like #1521. shiretu, does that ticket seem to match what you're seeing here?

comment:12 Changed 13 years ago by shiretu

Yes indeed. But with a little observation: is starting to act like this after 30~40 seconds from the application start. Didn't had time to recompile it last night as I promised but I'll do it tonight. For my early curiosity, what file descriptor reactor are you using? libevent, kqueue? I have great experiences using kqueue since for the signaling part (at least for sockets) you have 0 copy events.

comment:13 Changed 13 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, libevent, which on the mac uses kqueue.

Closing this ticket as a duplicate of #1521; let's continue this there.

Note: See TracTickets for help on using tickets.