Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1885 closed Bug (wontfix)

Can't build svn r7993 without glib-gettextize

Reported by: der_lunz Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.51
Severity: Normal Keywords: patch-needed
Cc:

Description

I just tried to build transmission from the SVN repository on my headless server.

running ./autogen.sh results in the an error message stating that something is wrong with the intltool version. Sorry, I don't have the output log, but I'm pretty sure it has to do with the following line in autogen.sh:

GETTEXTIZE="glib-gettextize"

Since glib is not installed on my machine, autogen.sh just breaks. I tried to replace "glib-gettextize" with "gettextize" which is on my machine. autogen works fine (modulo messages of gettextize), but make will result in the following output:

It seems you didn't check the case that glib-gettextize could be not available (in contrast to (g)libtoolize).

The whole autoconf/automake is kind of voodoo to me, so I didn't try to fix the problem

Attachments (2)

r8001-build-error (13.5 KB) - added by der_lunz 12 years ago.
Output of "autogen.sh --disable-nls"
fixup_autogen_glib-gettextize_issue.diff (1.8 KB) - added by der_lunz 12 years ago.
Only call glib-gettextify when gtk client will be built

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

I could be wrong, but I don't think glib-gettextize is the culprit here. It sounds more like you didn't pass --disable-nls along to the configure script...?

If I'm wrong, please reopen the ticket. Also feel free to drop by #transmission on freenode if you want to chat about it. :)

comment:2 Changed 12 years ago by der_lunz

  • Resolution invalid deleted
  • Status changed from closed to reopened

I just tried your advice on r8001:

1) svn co .... 2) autogen.sh --disable-nls

Output:

....
config.status: creating wx/images/Makefile
config.status: creating gtk/Makefile
config.status: creating gtk/icons/Makefile
config.status: error: cannot find input file: po/Makefile.in.in

Now type 'make' to compile Transmission.

3) make

Making all in doc
make[1]: Entering directory `/home/chrkap/src/Transmission/doc'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/chrkap/src/Transmission/doc'
Making all in third-party
make[1]: Entering directory `/home/chrkap/src/Transmission/third-party'
Making all in libevent
make[2]: Entering directory `/home/chrkap/src/Transmission/third-party/libevent'
make[2]: *** No rule to make target `all'.  Stop.
make[2]: Leaving directory `/home/chrkap/src/Transmission/third-party/libevent'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/chrkap/src/Transmission/third-party'
make: *** [all-recursive] Error 1

I attached the whole output as file.

I tracked it down, to the missing ./po/Makefile.am . Because configure can't find ./po/Makefile.in it terminates, without creating other Makefile. As consequence the make step is not successful.

Changed 12 years ago by der_lunz

Output of "autogen.sh --disable-nls"

comment:3 Changed 12 years ago by davy_gravy

I can confirm this ... seeing the same thing. I'm crosscompiling, but 1.3x-1.4x built fine for me for all my target platforms. Neither of the 1.5x versions build, due to this problem. I also have disabled NLS.

comment:4 Changed 12 years ago by charles

@davy_gravy: are you building from svn, or from a tarball?

@der_lunz, davy_gravy: are you able to build from the nightly tarballs?

comment:5 Changed 12 years ago by davy_gravy

hi charles,

I'm building from the tarball ...

comment:6 Changed 12 years ago by der_lunz

Building from nightly tarball works, since the configure script is already in place there.

I made a crude patch which just calls glib-gettextify, only if the gtk client is requested.

BTW it seems to me that it is intended to call [glib-]gettextify just once to adapt the build system for internationalization. Once this is done those tools aren't needed anymore.

Changed 12 years ago by der_lunz

Only call glib-gettextify when gtk client will be built

comment:7 Changed 12 years ago by charles

I really don't like that patch. Its downside is that it forces everyone building the gtk client to have intltoolize installed. That is a much higher overall burden. :(

If there's not a way to patch this more cleanly, I'm leaning towards closing this as a wontfix because lots of people report that building from tarballs works. If you can figure out a cleaner solution I'm happy to listen... I've tried to figure one out too, but intltoolize is kind of a burden wrt expecting things to be a certain way.

Also I'm not sure why building from the tarballs works for one of you but not the other. Are there two separate issues here?

comment:8 Changed 12 years ago by livings124

  • Resolution set to wontfix
  • Status changed from reopened to closed

Closing until a cleaner solution is offered.

comment:9 Changed 12 years ago by charles

Ticket #2130 has been closed as a duplicate of this ticket.

comment:10 Changed 12 years ago by charles

  • Keywords patch-needed added

Ticket #2350 has been closed as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.