Opened 13 years ago

Closed 13 years ago

#1893 closed Bug (worksforme)

transmission-gtk crashes when choosing OK on new torrent too fast

Reported by: costela Owned by: charles
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 1.51
Severity: Normal Keywords:
Cc:

Description

Originally reported here for 1.33, but I just confirmed it in 1.51.

I can replicate it, though not reliably. I couldn't pin down the exact situations in which this happens, but the torrent drop-down sometimes takes a while to load the torrent information and clicking OK while it loads leads to a crash.

Possibly related to 1762?

(I admit I've been a lazy maintainer and haven't even checked the code for a possible solution... )

Please let me know if you need more info!

Cheers

Change History (7)

comment:1 Changed 13 years ago by charles

I can't reproduce this at all, no matter how fast I close the "Add" dialog. Even just hitting alt-a, alt-a to open the "Add" dialog & close it, it's not happening for me.

comment:2 Changed 13 years ago by costela

I reproduced it only once today, on the first run of transmission, being run directly from Firefox. It took 1, perhaps 2 seconds, until the drop-downs got filled, so it was pretty easy to see, but I couldn't reproduce it later as well, even after a reboot.

This is specially annoying, since this bug is kindda old and I wasn't able to reproduce it at first either. Today I just was doing some triaging on my bugs, decided to check it again and there it was.

Can we just leave this bug open for some time as a point of reference? If I or the original reporter can find out how to reproduce it I'll update it...

comment:3 Changed 13 years ago by charles

Can you reproduce it inside a gdb session of Transmission compiled with --ggdb3 to get a good backtrace?

If so, note that transmission handles SIGPIPE, but for some reason gdb un-handles it, so in gdb you'll need to "handle SIGPIPE nostop noprint nopass" in order for things to run correctly...

comment:4 Changed 13 years ago by costela

I'll try to do it during the weekend.

comment:5 Changed 13 years ago by charles

@costela: any news?

comment:6 Changed 13 years ago by costela

No, I wasn't able to reproduce it. If you want you can close this as worksforme and I'll leave the original Debian bug report open as reference. If someone else appears with the same problem and is able to reproduce it, I'll report back.

Cheers

comment:7 Changed 13 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.