Opened 13 years ago

Closed 13 years ago

#1912 closed Bug (fixed)

Web Client broken in Safari 4

Reported by: caius Owned by: Gimp
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.51
Severity: Normal Keywords:
Cc:

Description

I load up the web client in Safari 4 and the interface loads, but no torrents appear in the window. I'm running the latest Webkit nightly, r41521. It works fine in the standard Safari 4 beta.

In the JS Console I see the following:

TypeError: Result of expression 'stack[i].style' [undefined] is not an object.    jquery.min.js:98
TypeError: Result of expression 'tr' [undefined] is not an object.                transmission.js:427

Attachments (3)

webkit.png (75.1 KB) - added by bigtex 13 years ago.
Webkit r42142
minefield.png (162.7 KB) - added by bigtex 13 years ago.
works fine in Minefield
app.png (27.5 KB) - added by bigtex 13 years ago.
plenty of transfers in the app, just not showing in Webkit

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by livings124

  • Component changed from Transmission to Web Client
  • Owner set to Gimp

Since you're running a webkit nightly, have you reported this to them?

comment:2 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

The latest nightly works fine for me with Webkit 41545.

Changed 13 years ago by bigtex

Webkit r42142

Changed 13 years ago by bigtex

works fine in Minefield

Changed 13 years ago by bigtex

plenty of transfers in the app, just not showing in Webkit

comment:3 Changed 13 years ago by bigtex

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm using the latest nightly on top of Safari 4 beta: Version 4 Public Beta (5528.16, r42142)

I get the same behavior. It works fine in all other browsers including the latest Minefield nightly, normal Firefox, Safari 3, and normal Safari 4 beta. I've got 16 transfers open, but none show up in the web interface through Webkit. See attached screenshots.

I've also filed a bug with Webkit, but since this was closed as working, I thought maybe it should be reopened.

comment:5 Changed 13 years ago by vaska

I get this too in recent Webkits and Transmission 1.51. But it works fine in the Transmission nightlies, so something that's already been done fixed it. bigtex, you might try some nightlies to see if you can find which one fixed it. Then if they think it necessary the devs could add that change to an earlier release.

comment:6 Changed 13 years ago by bigtex

  • Resolution set to fixed
  • Status changed from reopened to closed

Confirmed as working in latest nightly: 1.51+ (8128) Looks like whatever it was has already been fixed by the Transmission team.

Note: See TracTickets for help on using tickets.