Opened 13 years ago

Closed 13 years ago

#1936 closed Bug (invalid)

Checking existing data on a large number of torrents causes Transmission and OS X's systemUIServer to lock up.

Reported by: jonfleck88 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.51
Severity: Normal Keywords:
Cc:

Description

The error can be reproduced by having 23 active transfers (that's just the number I had, I imagine that you don't need this many) and Force Quit Transmission. This will cause transmission to check existing data on all of the active torrents and crash itself as well as my whole system. The simple solution to this problem is to pause all transfers and go though and resume one transfer, let it finish checking existing data and then repeat for each active transfer. I know that you may think this is a problem with my system, but from a users standpoint that doesn't make sense. Seeing as when I resume all transfers Transmission only checks existing data one file at a time and just queues the rest of them.

Hope you actually try to resolve this problem. I've seen that you have closed a couple other tickets on other people citing the problem was their systems fault. Clearly it isn't because resuming one transfer at a time manually is any more straining than letting Transmission automatically check data for my transfers one at a time.

Thank you for a great piece of software. Hope you don't continue to ignore this error, as it could be show stopper for somebody that doesn't know to manually check existing data on each transfer one at a time.

Change History (9)

comment:1 Changed 13 years ago by jonfleck88

BTW I'm using OS X 10.5.6 on an Intel MacBook? with 4 GB of ram, wireless N on an Airport router.

comment:2 Changed 13 years ago by livings124

Instead of lecturing us, can you post a crash log?

comment:3 Changed 13 years ago by livings124

And why are you force-quitting Transmission? Obviously that would not result in ideal behavior.

comment:4 Changed 13 years ago by jonfleck88

Haha, sorry for the lecture. There are no crash logs, the whole system just slows and stops responding.

I'm just force quitting Transmission to get it to check existing data as it would after a crash. Originally, I had a Kernel Panic that was unrelated to Transmission, but when I restarted and Transmission started trying to check data is when the Transmission problem started.

comment:5 Changed 13 years ago by charles

I can't reproduce this problem. When I try what you described, Transmission restarts and checks the torrents one at a time.

comment:6 Changed 13 years ago by livings124

Are you sure it's checking them all at the same time? They don't say anything along the lines of "waiting to check"?

comment:7 Changed 13 years ago by jonfleck88

No, it doesn't check them all at the same time. It checks one at a time and says "waiting to check" for the rest. Transmission will successfully check a couple of the torrents and then eventually crash.

comment:8 Changed 13 years ago by livings124

Again, if it's crashing post a crash log. But this sequential check is 100% intentional (and I don't see how it's different then doing it manually like you said).

comment:9 Changed 13 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Nothing we can do about all the hash checks - they're desired and there's not much that can be done to make them less resource-intensive. And they only occur when the app crashes.

Note: See TracTickets for help on using tickets.