Opened 12 years ago

Closed 12 years ago

#1937 closed Bug (duplicate)

Curl doesn't resolve ipv6 formed address

Reported by: Magicking Owned by: jhujhiti
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.51
Severity: Normal Keywords: dns ipv6 curl
Cc:

Description

As said in the title the CURL can't open links like http[::1]/.

The bug is due to the CURL_IPRESOLVE_V4 option in libtransmission/web.c (line 195, in 1.51+)

I solved it by changing :

curl_easy_setopt( easy, CURLOPT_IPRESOLVE, CURL_IPRESOLVE_V4 );

to

curl_easy_setopt( easy, CURLOPT_IPRESOLVE, CURL_IPRESOLVE_WHATEVER );

Change History (2)

comment:1 Changed 12 years ago by livings124

  • Owner changed from charles to jhujhiti

comment:2 Changed 12 years ago by jhujhiti

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1731. This is intentionally broken for a bit.

Note: See TracTickets for help on using tickets.