Opened 13 years ago

Closed 13 years ago

#1948 closed Bug (invalid)

Transmission hangs with external hard drive

Reported by: vbeffa Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.51
Severity: Normal Keywords:
Cc:

Description

Diid a search for 'hangs' and didn't find a match. Transmission sometimes just hangs, the interface becomes unresponsive. Force quit doesn't work. Shut down or restart doesn't even work. I have to hold the power key down to kill the system and then repower.

I am also usually running Xtorrent at the same time. I have noticed that Xtorrent has done the same thing but it doesn't happen as frequently. After Transmission hangs I can still use the network, check email, download via Xtorrent. But I can't kill Transmission and restart my downloads without a hard shutdown and restart. Very annoying.

I am running Mac 10.4.11 on a 1.67 GHz PowerPC with 1 GB of RAM. I have only 5 or 6 downloads in Transmission, going to an external USB hard drive.

Change History (15)

comment:1 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Downloading to an external harddrive is inherently slow. This is most likely a result of that. Try downloading to your internal harddrive.

comment:2 Changed 13 years ago by vbeffa

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm confused by your terminology. You set the resolution to "worksforme." Does this mean you tested things the way I described above? Or was it just a convenient and quick way to ignore the real problem?

Also, you say that an external hard drive is "inherently slow." Do you mean that after a while Transmission will respond again? Because I've waited hours and Transmission is still hung.

I can't use my internal hard drive because it doesn't have enough free hard disk space on it. It's not inherently slow, because the read/write rate is faster than my network download rate. I rarely get above 150Kb/sec network speed.

comment:3 follow-up: Changed 13 years ago by livings124

The fact remains that downloading to an external drive is not the ideal setup. And the fact that you said other similar apps cause the same problem helps confirm this. Have you tried limiting the number of active torrents to 1 or 2 at a time?

comment:4 Changed 13 years ago by livings124

And you say your running xtorrent at the same time? Are you downloading the same torrents with it? That's a horrible idea and can cause corruption and other issues.

comment:5 Changed 13 years ago by vbeffa

Actually Xtorrent is downloading only to my hard drive. I take my laptop with me sometimes and try to use other people's connections to download, so in that case I have to download only to my hard drive since I don't take the external drive with me.

And absolutely not, I'm not downloading duplicate torrents - I pay for my internet at home by volume or data, so I don't waste bandwidth.

I can understand if I was downloading 50 or 100 torrents at the same time that that might cause problems. But 5 or 10? It really seems that an application should handle that gracefully without hanging. If indeed it is an OS problem as others have implied, then it would be nice to determine this definitively and report the bug to Apple and make them responsible for fixing it.

But I'll try limiting concurrent downloads to 3 and see if it still hangs.

comment:6 Changed 13 years ago by vbeffa

(Xtorrent has even worse behavior in that if you start it without your external hard drive attached and you were downloading some torrents to it, it gives you the option to either quit or restart those torrents from the beginning - not pause them. So I moved all my Xtorrent downloads to my internal drive.)

comment:7 in reply to: ↑ 3 Changed 13 years ago by vbeffa

Replying to livings124:

The fact remains that downloading to an external drive is not the ideal setup. And the fact that you said other similar apps cause the same problem helps confirm this. Have you tried limiting the number of active torrents to 1 or 2 at a time?

I tried limiting the active transfers in Transfers -> Management, setting both download and seeding to a max of 3 (my upload rate on the Bandwidth panel is set to 0 kb/s, no limit on download). However even after quitting and restarting Transmission all my transfers are still active. Is there something else I have to do to limit the number of transfers?

comment:8 Changed 13 years ago by livings124

Pause all and resume all.

comment:9 follow-up: Changed 13 years ago by livings124

Did that do anything?

comment:10 in reply to: ↑ 9 Changed 13 years ago by vbeffa

Replying to livings124:

Did that do anything?

Yeah that did the trick. Let me run it for a while and see if it still hangs.

comment:11 follow-ups: Changed 13 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

So, in summary, it WAS the system or WAS the network the couldn't handle the amount of connections.

comment:12 in reply to: ↑ 11 Changed 13 years ago by vbeffa

Replying to livings124:

So, in summary, it WAS the system or WAS the network the couldn't handle the amount of connections.

No, when I said that did the trick, I meant it limited the number of concurrent downloads to 3, not that it solved the hanging problem. That's why I said, let me run it for a while to see if it still hangs.

comment:13 in reply to: ↑ 11 Changed 13 years ago by vbeffa

Replying to livings124:

So, in summary, it WAS the system or WAS the network the couldn't handle the amount of connections.

In the bug title, when I said NOT the system and NOT the network, I meant that it's not the system or network that's hanging as I saw in other bugs filed. In my situation I can still use both my system and the network.

comment:14 Changed 13 years ago by vbeffa

  • Priority changed from High to Normal
  • Resolution invalid deleted
  • Severity changed from Major to Normal
  • Status changed from closed to reopened

I got Transmission to hang again. This time I was running only one download to my external hard drive. Xtorrent was not running. It hung at a download rate of 37Kb/sec after just a few minutes. It seems the only time I've had problems with my external hard drive has been in using Transmission. I understand it's not ideal to download to an external hard drive, however it seems Transmission should be able to handle one download at a moderate download rate.

I'm reopening the bug but changing the priority and severity to normal.

comment:15 Changed 13 years ago by vbeffa

  • Resolution set to invalid
  • Status changed from reopened to closed
  • Summary changed from Transmission hangs (NOT the system, NOT the network) to Transmission hangs with external hard drive

After some more testing it seems the problem is with the external hard drive because it sometimes hangs other applications too. So I'll close the bug and reopen it if I can get Transmission to hang with the internal hard drive. I'm also changing the bug title.

Note: See TracTickets for help on using tickets.