Opened 13 years ago

Closed 12 years ago

#1956 closed Bug (duplicate)

Updated torrent named same as old removed one doesn't announce, connect or xfer after verify

Reported by: Lacrocivious Owned by: charles
Priority: Normal Milestone: Sometime
Component: GTK+ Client Version: 1.51
Severity: Normal Keywords:
Cc:

Description

Some torrents are updated over time, containing supersets of older torrents bearing the same name throughout their update-to-final history. When the old torrent is removed from the client, and a new version downloaded overwriting the old torrent -- regardless of 'Start when Added' setting -- the new torrent when added begins a Verify pass as it should. However, when the verification completes, the client fails to announce that torrent, ever. Properties/Tracker? dialog even shows: Last announce at: Never ... Next announce in: Never. *Immediately* upon a manual Pause/Start?, client connects to peers and begins uploading/downloading. Without manual Pause/Start?, it never connects or transfers.

Change History (9)

comment:1 Changed 13 years ago by charles

  • Component changed from GTK+ Client to libtransmission
  • Milestone changed from None Set to 1.60
  • Status changed from new to assigned

comment:2 Changed 13 years ago by charles

Are you still seeing this behavior in the nightlies?

comment:3 Changed 13 years ago by charles

  • Component changed from libtransmission to GTK+ Client

According to Lacrocivious in irc, this behavior only happens for him in the gtk+ client, but not in the daemon or qt client...

comment:4 Changed 12 years ago by charles

  • Milestone changed from 1.60 to Sometime

This isn't a showstopper for 1.60.

comment:5 Changed 12 years ago by charles

Lacrocivious: does this still occur in >= r8389 ?

comment:6 Changed 12 years ago by charles

  • Summary changed from Updated torrent named same as old removed one does not accounce, connect or xfer after verify pass to Updated torrent named same as old removed one doesn't accounce, connect or xfer after verify

comment:7 Changed 12 years ago by charles

  • Summary changed from Updated torrent named same as old removed one doesn't accounce, connect or xfer after verify to Updated torrent named same as old removed one doesn't announce, connect or xfer after verify

comment:8 Changed 12 years ago by 103450

I'm experiencing this same behavior using the latest Gtk client from the ubuntu-nightlies as of 5-20 v1.61 +. When you add a new torrent and click 'start when added' it fails to announce the torrent but it does scrape the tracker. If you pause then start it works fine. This goes either way if it's a new torrent with no data or after data verification. Maybe I should make a seperate bug/ticket, thought I'd chime in any case.

comment:9 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing this bug as duplicate of #1864

Note: See TracTickets for help on using tickets.