Opened 12 years ago

Closed 12 years ago

#1957 closed Enhancement (invalid)

[PATCH] Default to XDG Download directory for downloaded files

Reported by: lkundrak Owned by: charles
Priority: Lowest Milestone:
Component: libtransmission Version: 1.50
Severity: Normal Keywords:
Cc: kab

Description

Use the XDG download directory for downloads instead of made-up unusally nonesixtent ~/Downloads (fall back to it in case there's no XDG user dir configuration).

This was stolen from gthumb, though it probably originates from xdg-user-dirs's xdg-user-dir-lookup.c. See: http://www.redhat.com/archives/fedora-devel-list/2007-March/msg00677.html

And no, there's no library for XDG dirs.

Attachments (1)

transmission-1.51-xdg-download-dir.patch (3.7 KB) - added by lkundrak 12 years ago.

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by lkundrak

comment:1 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 1.52
  • Owner set to charles
  • Status changed from new to assigned

Committed to trunk (for 1.60) in r8136.

Committed to 1.5x (for a *possible* 1.52) in r8137.

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 12 years ago by charles

  • Cc kab added
  • Milestone changed from 1.52 to 1.60
  • Priority changed from Normal to Lowest
  • Version changed from 1.51 to 1.50

Comment:

Transmission should check if the file .config∕user-dirs.dirs is readable and not necesserly throw an error if not. The problem is when you start transmission-daemon as an other user, transmission tries to read .config ∕user-dirs.dirs of the user logged in. This will always throw an error like:

[18:42:09.716] Couldn't read "/home/sampleuser/.config/user-dirs.dirs":
Permission denied

comment:4 Changed 12 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 12 years ago by charles

  • Milestone 1.60 deleted

kab: actually in this instance it seems like it would be a good idea to log the error. If /home/sampleuser/.config/users-dirs.dirs isn't readable, then the fallback download directory of /home/sampleuser/Downloads probably isn't reachable either...

comment:6 Changed 12 years ago by charles

lkundrak: ping

comment:7 Changed 12 years ago by charles

oops, I meant to ping kab :)

comment:8 Changed 12 years ago by charles

kab: please reopen this ticket when you pong

comment:9 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.