Opened 15 years ago

Closed 15 years ago

#199 closed Defect (worksforme)

[PATHC] ./configure breaks with gtk newer than 2.10 because of bad comparison (lexical instead of numerical)

Reported by: ernstp Owned by: somebody
Priority: Highest Milestone: Sometime
Component: Transmission Version: 0.6
Severity: Blocker Keywords:
Cc:

Description

Patch:

Index: configure =================================================================== --- configure (revision 1451) +++ configure (arbetskopia) @@ -174,7 +174,7 @@

verbose gtk_test if runcmd pkg-config gtk+-2.0 then

  • if runcmd pkg-config --exists gtk+-2.0 '>=' 2.6.0

+ if runcmd pkg-config --atleast-version=2.6.0 gtk+-2.0

then

cat > testconf.c << EOF #include <gtk/gtk.h>

Change History (4)

comment:1 Changed 15 years ago by joshe

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed in svn shortly after the 0.6.1 release.

comment:2 Changed 15 years ago by ernstp

  • Resolution fixed deleted
  • Status changed from closed to reopened

How is this fixed? It still says

if runcmd pkg-config --exists gtk+-2.0 '>=' 2.6.0

on http://transmission.m0k.org/cgi-bin/trac.cgi/browser/trunk/configure#L177 instead of

if runcmd pkg-config --atleast-version=2.6.0 gtk+-2.0

comment:3 Changed 15 years ago by joshe

I'm sorry, I thought you were referring to the broken check in the 0.6.1 configure script. The current comparison is in fact numeric and works just fine with 2.10.6 on my system. Could you post the output of these two commands please?

pkg-config gtk+-2.0 --modversion
pkg-config --exists gtk+-2.0 '>=' 2.6.0; echo $?

comment:4 Changed 15 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

No response in 2 months and no other reports.

Note: See TracTickets for help on using tickets.